Warning: file_exists(): open_basedir restriction in effect. File(/srv/http/vhosts/aur.archlinux.org/public/web/locale//en/LC_MESSAGES/aurweb.mo) is not within the allowed path(s): (/srv/http/vhosts/aur-dev.archlinux.org/:/etc/aurweb/) in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/streams.php on line 90
AUR (en) - gimp-gtk3-git

Notice: Undefined variable: name in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/pkgfuncs.inc.php on line 248

Package Details: gimp-gtk3-git 2.9.2.r933.gfc73b32-1

Git Clone URL: https://aur-dev.archlinux.org/gimp-gtk3-git.git (read-only)
Package Base: gimp-gtk3-git
Description: GNU Image Manipulation Program
Upstream URL: http://www.gimp.org
Licenses: GPL, LGPL
Conflicts: gimp-2.99
Provides: gimp-2.99
Replaces: gimp-2.99
Submitter: ksj
Maintainer: ksj
Last Packager: ksj
Votes: 13
Popularity: 1.028556
First Submitted: 2013-07-29 07:33
Last Updated: 2016-04-15 12:39

Dependencies (30)

Required by (0)

Sources (2)

Latest Comments

1 2 3 4 5 6 Next › Last »

sergey.orloff commented on 2016-12-11 06:53

OK! I rebuilt and it worked. It is strange that the version information gegl-git package is false.

==> Завершена сборка пакета gegl-git 0.3.10.52.g9b3e942-1 (Вс дек 11 11:45:21 +05 2016)
==> Установка пакета 'gegl-git' с помощью 'pacman -U'...
[sudo] пароль для sergey:
загрузка пакетов...
разрешение зависимостей...
проверка конфликтов...

Пакеты (1) gegl-git-0.3.10.52.g9b3e942-1

Будет установлено: 11,39 MiB
Изменение размера: -1,27 MiB

:: Приступить к установке? [Y/n] y
(1/1) проверка ключей [######################] 100%
(1/1) проверяется целостность пакета [######################] 100%
(1/1) загрузка файлов пакетов [######################] 100%
(1/1) проверка конфликтов файлов [######################] 100%
(1/1) проверяется доступное место [######################] 100%
:: Processing package changes...
(1/1) обновление gegl-git [######################] 100%

sergey.orloff commented on 2016-12-11 04:23

Hi @ksj!
Please tell me where you have gegl-0.3> = 0.3.10?
Following the 'https://aur.archlinux.org/packages/gegl-git/' link on this page
I offer package: gegl-git 0.3.8.20.gf361098-1.
How did you build gimp-gtk3-git?
I would be grateful for clarification.
Thank You!

ksj commented on 2016-12-08 08:05

This gimp has gegl git version. Have you tried rebuild gegl package?

electricprism commented on 2016-12-08 07:49

Error: GIMP configuration failed.

- Error: missing dependency gegl-0.3 >= 0.3.10

electricprism commented on 2016-10-05 01:41

I see movement over here:
https://git.gnome.org/browse/gimp/log/?h=gtk3-port

But I'm not sure the AUR calls for a update every time there's a new commit, if so do I have to manually recompile the PKGBUILD and install? It seems like it.

electricprism commented on 2016-07-04 23:57

It seems that ankh from irg.gimp.org#gimp has helped me to determine that there is a VIRT MMap bug in the GTK3 branch that doesn't allow .xcf.gz or other Export As file types to be saved.

A temporary solution is override the memory limit as root:
sudo sh -c ' echo 1 > /proc/sys/vm/overcommit_memory'

If anyone has the skills to fix it, a fix would be welcome upstream - thanks :)

CAUTION *****
running a system with overcommitted memory can cause other programs to crash at random times later
so, when you have finished with gimp you might want to set it back to 0

electricprism commented on 2016-07-04 22:20

@Nordlicht: I'll recompile now - the error on Export As > PNG is this:

Unable to run plug-in "file-png"
(/usr/lib/gimp/3.0/plug-ins/file-png)

Failed to fork (Cannot allocate memory)

Nordlicht commented on 2016-05-20 12:31

Works fine here. Have you tried a full recompile (including the needed babl, gegl and libmypaint git packages)?

electricprism commented on 2016-05-17 08:54

When saving/exporting a PNG

Saving '/home/electricprism/Untitled.png' failed:

Failed to run plug-in "file-png"

Ilya87 commented on 2016-04-19 04:22

New segfault appears. The reason now is unclear. It's GIMP gtk3 branch bug.