Warning: file_exists(): open_basedir restriction in effect. File(/srv/http/vhosts/aur.archlinux.org/public/web/locale//en/LC_MESSAGES/aurweb.mo) is not within the allowed path(s): (/srv/http/vhosts/aur-dev.archlinux.org/:/etc/aurweb/) in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/streams.php on line 90
AUR (en) - get-flash-videos-git

Notice: Undefined variable: name in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/pkgfuncs.inc.php on line 248

Package Details: get-flash-videos-git v1.22.556.g2d46d08-1

Git Clone URL: https://aur-dev.archlinux.org/get-flash-videos-git.git (read-only)
Package Base: get-flash-videos-git
Description: Downloads videos from various Flash-based video hosting sites
Upstream URL: http://code.google.com/p/get-flash-videos
Licenses: Apache
Conflicts: get-flash-videos, get_flash_videos
Provides: get-flash-videos, get_flash_videos
Submitter: matthewbauer
Maintainer: None
Last Packager: drrossum
Votes: 30
Popularity: 0.000001
First Submitted: 2010-04-04 04:55
Last Updated: 2015-07-29 21:23

Latest Comments

« First ‹ Previous 1 2 3 4 Next › Last »

jsteel commented on 2013-03-28 18:50

Ah, perl-universal-require is also needed; removing it causes that error. It should be a dep of perl-data-amf so I have asked for it to be added there. Please try installing it to confirm if that's OK now. Thanks.

jsteel commented on 2013-03-28 18:09

@Army: Works for me. What's your output of:
pacman -Qi {perl-data-amf,perl-any-moose} | grep Name -A1

Anonymous comment on 2013-03-28 16:51

Hmmm, I tried the failed command and look what I get...:

$ get_flash_videos http://www.ustream.tv/recorded/8612469
Using method 'ustream' plugin version 0.01 for http://www.ustream.tv/recorded/8612469
Downloading http://www.ustream.tv/recorded/8612469
Must have Data::AMF::Packet installed to download ustream videos at /usr/lib/perl5/site_perl/FlashVideo/Site/Ustream.pm line 15.
A required Perl module for downloading this video is not installed.
Couldn't download any videos.

Anonymous comment on 2013-03-28 16:39

Those are a lot of dependencies! Hope it doesn't break all the time! ;)

Thanks for the update!

jsteel commented on 2013-03-28 16:26

@Army and Hermano_Arco: All sorted.

jsteel commented on 2013-03-24 20:54

@ilikenwf which script?

I think perl-any-moose should be a dep of Perl Data AMF, so I'm seeing if I can get it added to perl-data-amf-packet if that's the right place. If not, I'll add it here.

ilikenwf commented on 2013-03-23 20:28

You need to set the script as executable in your PKGBUILD.

jsteel commented on 2013-03-21 18:43

They un-deleted my report. Turns out perl-any-moose is needed. I've tested and can confirm that fixes downloading from ustream. I'll update this package soon.

jsteel commented on 2013-03-19 21:17

Still no luck with Ustream so I submitted a bug report[1] but it says it's been deleted. I tried again and the same thing happened. Here's a copy of the report[2].

[1] http://code.google.com/p/get-flash-videos/issues/detail?id=481
[2] http://pastie.org/pastes/6632285/text?key=92espz42ewqytbrq7uogw

Anonymous comment on 2013-03-11 16:19

Worked fine. Just had to setup Cpan and run: cpan Module::Find
I also removed the perl-universal-require from the dependencies list because I'm running from a Raspberry Pi and we don't have that package.