Notice: Undefined variable: name in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/pkgfuncs.inc.php on line 248

Package Details: gcc-gcj 6.3.1-2

Git Clone URL: https://aur-dev.archlinux.org/gcc-gcj.git (read-only)
Package Base: gcc-gcj
Description: The GNU Compiler for Java
Upstream URL: http://gcc.gnu.org
Licenses: GPL, LGPL
Submitter: Allan
Maintainer: valandil
Last Packager: valandil
Votes: 243
Popularity: 3.271133
First Submitted: 2009-05-08 17:48
Last Updated: 2017-01-14 15:55

Pinned Comments

valandil commented on 2016-05-11 14:02

This package, gcc-gcj, is a subset of the GNU Compiler Collection, specifically the Java compiler part. In Arch Linux, it is mostly used to compile pdftk, a very nifty command-line PDF tool.

When reporting any build issue, please provide your current version of gcc and any error message.

It is *very* long to compile and takes up a lot of disk space while doing so. Do not use AUR helpers to compile this thing, you'll probably end up filling your /tmp partition and crash the compilation process. Download the PKGBUILD (either with yaourt -G gcc-gcj, with the helper of your choice or even manually) and run makepkg.

If you do not want to compile this and only need it for pdftk, consider using pdftk-bin. As its name indicates, it is a precompiled version of pdftk and depends only on libgcj, also precompiled.

Latest Comments

« First ‹ Previous ... 4 5 6 7 8 9 10 11 12 13 14 ... Next › Last »

Rhinoceros commented on 2014-11-19 10:28

It looks like the dependency cloog (and its dependency isl) have been removed from AUR.

valandil commented on 2014-09-18 13:07

I know, it's terrible. Consider using the binary version (https://wiki.archlinux.org/index.php/Unofficial_user_repositories#kps).

narunas commented on 2014-09-18 05:35

Required 3977112 (3.8GB) on my machine to compile, produced 24120 (24M) tarball o_O
And I needed it just as dependency for pdftk

valandil commented on 2014-09-02 12:17

@hepha
If you are not compiling from a seperate build directory, like I indicated in one of my earlier comments, try this. If this doesn't work, I do not know what's wrong, as everything compiles fine on my end.

@mindbound
Nope. I can build this package fine with g++ 4.9.1. In fact, the last version requires this version.

hepha commented on 2014-08-30 21:38

@OdinEidolon
Your error message
Makefile: 20145: recipe for target 'stage1-bubble' failedMakefile: 20145: recipe for target 'stage1-bubble' failed

The top is not like I have this message
recipe for target 'floatformat.o' failed

I also fail to compile and today I find problems with the clang fails
Gcc changed back to normal I hope for your help

mindbound commented on 2014-08-12 20:53

It seems that I can reproduce this with *any* code that contains `#include <iostream.h>` (as opposed to <iostream>) on g++ 4.9.1. Has gcc/g++ stopped including the old C-style headers?

mindbound commented on 2014-08-12 20:52

The problem seems to be reproducible with *any* code that contains `#include <iostream.h>` (as opposed to <iostream>) on g++ 4.9.1. Has gcc/g++ stopped including the old C-style headers?

valandil commented on 2014-08-12 14:17

@mindbound I cannot reproduce the issue at work. I'll try this on my other laptop at home.

mindbound commented on 2014-08-12 03:57

Building via makepkg in a separate directory yields the same result as before.

This can't be caused by lack of space, too (I have more than 1TB free space in my home partition, and compiler emits the error within the first few minutes into the build).

mindbound commented on 2014-08-12 03:56

Building via makepkg in a separate directory yields the same result as before.

This can't be caused by lack of space, too (I have more than 1TB free space in my home partition, and compiler emits the error in the first few minutes into the build).