Notice: Undefined variable: name in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/pkgfuncs.inc.php on line 248

Package Details: fwupd 0.7.5-1

Git Clone URL: https://aur-dev.archlinux.org/fwupd.git (read-only)
Package Base: fwupd
Description: A simple daemon to allow session software to update firmware
Upstream URL: https://github.com/hughsie/fwupd
Licenses: GPL2
Submitter: mirco
Maintainer: mirco
Last Packager: mirco
Votes: 28
Popularity: 1.398686
First Submitted: 2015-06-24 16:41
Last Updated: 2016-10-30 18:31

Latest Comments

1 2 3 Next › Last »

njam commented on 2017-02-02 20:13

I too get an error during compilation related to polkit:

/usr/include/glib-2.0/glib/gmacros.h:430:43: error: redefinition of ‘glib_autoptr_cleanup_PolkitAuthorizationResult’
#define _GLIB_AUTOPTR_FUNC_NAME(TypeName) glib_autoptr_cleanup_##TypeName

sQVe commented on 2017-01-24 07:55

I'm unable to build this package with the new polkit version 0.113+29+g3272a98-1.

I had to downgrade polkit to 0.113-4 for the build to go through.

ArchangeGabriel commented on 2016-11-01 18:54

@rafaelff: You need to update fwupdate first.

rafaelff commented on 2016-11-01 15:55

I'm unable to build this package. See full log in here: http://pastie.org/10953904 . The last messages are:

CC fwupd-fu-main.o
CC fwupd-fu-provider-chug.o
CC fwupd-fu-provider-uefi.o
CCLD fwupd
/usr/bin/ld: warning: libefivar.so.0, needed by /usr/lib64/libfwup.so, not found (try using -rpath or -rpath-link)
/usr/bin/ld: warning: libefiboot.so.0, needed by /usr/lib64/libfwup.so, not found (try using -rpath or -rpath-link)
/usr/lib64/libfwup.so: undefined reference to `efi_loadopt_create@libefiboot.so.0'
/usr/lib64/libfwup.so: undefined reference to `efi_loadopt_path@libefiboot.so.0'
/usr/lib64/libfwup.so: undefined reference to `efi_generate_file_device_path@libefiboot.so.0'
/usr/lib64/libfwup.so: undefined reference to `efi_loadopt_is_valid@libefiboot.so.0'
/usr/lib64/libfwup.so: undefined reference to `efi_loadopt_pathlen@libefiboot.so.0'
/usr/lib64/libfwup.so: undefined reference to `efi_loadopt_attr_set@libefiboot.so.0'

mirco commented on 2016-10-30 13:34

Sorry for the delay, I somehow missed the new versions. Update to 0.7.5 isn't trivial so it will need a couple days (currently trying to resolve another docbook related error).

As I currently don't own a supported device anymore, if someone else wants to step
up maintaining this please contact me.

devurandom commented on 2016-10-23 13:59

The issue reported by @rafaelff persists. Further, version 0.7.5 has been released in the meantime. Does this package need a new maintainer?

rafaelff commented on 2016-06-23 10:20

Thanks for updating to 0.7.2. By the way: 'configure: WARNING: unrecognized options: --enable-fwsignd' - nothing important, though.

rafaelff commented on 2016-06-21 21:09

It is solved in [testing] repo. Just please wait until new package release of 'opensp' lands [extra].

p.s.: 'perl-sgmls' should be added as makedepends of fwupd. This package provides '/usr/bin/sgmlspl' and it is optdepends of docbook-utils since release 0.6.14-8, currently in [testing] (see FS#49776), but without 'perl-sgmls' fwupd won't be able to use docbook-utils's backend\man script to create man pages.

mirco commented on 2016-06-20 22:06

Thanks, I've been meaning to do it myself but you beat me to it :) I will update the package when it's resolved.

rafaelff commented on 2016-06-20 11:50

Maintainer, for your information, I filed a bug against docbook-utils due to a bug that is avoiding fwupd to build: https://bugs.archlinux.org/task/49775