Warning: file_exists(): open_basedir restriction in effect. File(/srv/http/vhosts/aur.archlinux.org/public/web/locale//en/LC_MESSAGES/aurweb.mo) is not within the allowed path(s): (/srv/http/vhosts/aur-dev.archlinux.org/:/etc/aurweb/) in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/streams.php on line 90
AUR (en) - fpm

Notice: Undefined variable: name in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/pkgfuncs.inc.php on line 248

Package Details: fpm 1.6.0-1

Git Clone URL: https://aur-dev.archlinux.org/fpm.git (read-only)
Package Base: fpm
Description: Effing package management! Build packages for multiple platforms (deb, rpm, etc) with great ease and sanity.
Upstream URL: https://github.com/jordansissel/fpm
Keywords: deb packaging rpm ruby
Licenses: MIT
Submitter: markzz
Maintainer: None
Last Packager: markzz
Votes: 1
Popularity: 0.000374
First Submitted: 2015-12-06 19:48
Last Updated: 2016-05-28 18:00

Latest Comments

markzz commented on 2016-12-14 15:24

Yes, I know about the missing ruby dependencies, I just keep forgetting to get them fixed. I will work on it this weekend.

jeleniste commented on 2016-12-12 11:20

[jelen@laptak unip_tools]$ fpm --help
/usr/lib/ruby/2.3.0/rubygems/core_ext/kernel_require.rb:55:in `require': cannot load such file -- xz (LoadError)
from /usr/lib/ruby/2.3.0/rubygems/core_ext/kernel_require.rb:55:in `require'
from /usr/lib/ruby/gems/2.3.0/gems/backports-3.6.7/lib/backports/std_lib.rb:9:in `require_with_backports'
from /usr/lib/ruby/gems/2.3.0/gems/fpm-1.6.0/lib/fpm/package/freebsd.rb:6:in `<top (required)>'
from /usr/lib/ruby/2.3.0/rubygems/core_ext/kernel_require.rb:55:in `require'
from /usr/lib/ruby/2.3.0/rubygems/core_ext/kernel_require.rb:55:in `require'
from /usr/lib/ruby/gems/2.3.0/gems/backports-3.6.7/lib/backports/std_lib.rb:9:in `require_with_backports'
from /usr/lib/ruby/gems/2.3.0/gems/fpm-1.6.0/lib/fpm.rb:19:in `<top (required)>'
from /usr/lib/ruby/2.3.0/rubygems/core_ext/kernel_require.rb:55:in `require'
from /usr/lib/ruby/2.3.0/rubygems/core_ext/kernel_require.rb:55:in `require'
from /usr/lib/ruby/gems/2.3.0/gems/fpm-1.6.0/bin/fpm:5:in `<top (required)>'
from /usr/bin/fpm:22:in `load'
from /usr/bin/fpm:22:in `<main>'
[jelen@laptak unip_tools]$

dansteen commented on 2016-05-18 22:10

Ok. So I think the issue here (on my system) is that the ruby-<Gem> packages were installed under ruby 1.9.3. I have since installed ruby 2.3.0, but the gems are not included in that version. Once I manually installed the gems things all worked just fine.

TonyC commented on 2016-04-16 21:05

I had to explicitly install `ruby-ffi` or it wouldn't work.

markzz commented on 2016-01-18 20:14

Are you using Arch Linux? Why aren't use able to obtain/build ruby-backports 3.6.7-1? I can confirm this package works on a fully up to date Arch Linux system with the PKGBUILDs on the AUR and also from my personal repository [1].

If you are not using Arch Linux (derivative distributions of Arch), I'm not going to look into issues regarding this PKGBUILD.

If you are using Arch Linux, please tell the custom repository's maintainer to update his/her package because ruby-backports is NOT in core, extra, or community.

Here is an image of fpm working from my repository (and is built using this PKGBUILD). [2]

[1] https://wiki.archlinux.org/index.php/Unofficial_user_repositories#markzz
[2] http://images.markzz.com/fpm.png

axfelix commented on 2016-01-18 19:50

Any idea why this can't find backports after install? I never really touch the ruby environment on here...

[axfelix@nixon ~]$ sudo pacman -Syu ruby-backports
:: Synchronizing package databases...
core is up to date
extra is up to date
community is up to date
multilib is up to date
pipelight is up to date
archassault is up to date
archlinuxcn is up to date
antergos is up to date
warning: ruby-backports-3.6.0-1 is up to date -- reinstalling
:: Starting full system upgrade...
warning: linux: ignoring package upgrade (3.18.6-1 => 4.3.3-2)
warning: linux-headers: ignoring package upgrade (3.18.6-1 => 4.3.3-2)
warning: virtualbox: ignoring package upgrade (4.2.18-2 => 5.0.12-1)
warning: virtualbox-host-modules: ignoring package upgrade (4.3.24-1 => 5.0.12-2)
resolving dependencies...
looking for conflicting packages...

Packages (1) ruby-backports-3.6.0-1

Total Installed Size: 0.82 MiB
Net Upgrade Size: 0.00 MiB

:: Proceed with installation? [Y/n] n
[axfelix@nixon ~]$ fpm
/usr/lib/ruby/2.3.0/rubygems/dependency.rb:319:in `to_specs': Could not find 'backports' (>= 2.6.2) among 15 total gem(s) (Gem::LoadError)
Checked in 'GEM_PATH=/home/axfelix/.gem/ruby/2.3.0:/usr/lib/ruby/gems/2.3.0', execute `gem env` for more information
from /usr/lib/ruby/2.3.0/rubygems/specification.rb:1438:in `block in activate_dependencies'
from /usr/lib/ruby/2.3.0/rubygems/specification.rb:1427:in `each'
from /usr/lib/ruby/2.3.0/rubygems/specification.rb:1427:in `activate_dependencies'
from /usr/lib/ruby/2.3.0/rubygems/specification.rb:1409:in `activate'
from /usr/lib/ruby/2.3.0/rubygems/core_ext/kernel_gem.rb:68:in `block in gem'
from /usr/lib/ruby/2.3.0/rubygems/core_ext/kernel_gem.rb:67:in `synchronize'
from /usr/lib/ruby/2.3.0/rubygems/core_ext/kernel_gem.rb:67:in `gem'
from /usr/bin/fpm:22:in `<main>'

markzz commented on 2015-12-06 23:47

Seems like a reasonable thing to do. Done.

davidmcinnis commented on 2015-12-06 23:41

fpm relies upon the following orphaned packages:

ruby-arr-pm, ruby-cabin, ruby-clamp.

Would you consider adopting them?


Thanks

-Dave