Warning: file_exists(): open_basedir restriction in effect. File(/srv/http/vhosts/aur.archlinux.org/public/web/locale//en/LC_MESSAGES/aurweb.mo) is not within the allowed path(s): (/srv/http/vhosts/aur-dev.archlinux.org/:/etc/aurweb/) in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/streams.php on line 90
AUR (en) - foo2zjs-nightly

Notice: Undefined variable: name in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/pkgfuncs.inc.php on line 248

Package Details: foo2zjs-nightly 20161203-1

Git Clone URL: https://aur-dev.archlinux.org/foo2zjs-nightly.git (read-only)
Package Base: foo2zjs-nightly
Description: foo2zjs Printer Drivers (automatically updated). Includes also foo2hp, foo2hbpl, foo2oak, foo2xqx, foo2qpdl, foo2slx, foo2hiperc and foo2lava drivers.
Upstream URL: http://foo2zjs.rkkda.com/
Licenses: GPL, custom
Conflicts: foo2zjs
Provides: foo2zjs
Replaces: foo2zjs
Submitter: intelfx
Maintainer: intelfx
Last Packager: intelfx
Votes: 17
Popularity: 1.252232
First Submitted: 2016-11-12 03:35
Last Updated: 2016-12-04 13:18

Pinned Comments

intelfx commented on 2016-11-12 03:37

Package bumped. New package foo2zjs-nigtly has been uploaded which has a `pkgver()` function that extracts the timestamp from the driver's home page.

This should eliminate the need for frequent checksum mismatches and bump requests (provided that the patches will still apply). Please use that package, I'll request this one to be merged.

intelfx commented on 2016-10-23 00:02

@petres: Package bumped. I've completely rewritten printer firmware loading; please report if anything doesn't work (relevant for HP LaserJet printers).

intelfx commented on 2016-10-04 06:21

From now on, foo2zjs is decoupled from foomatic-db and does not require using the patched foomatic-db-foo2zjs package (nor does it require foomatic-db at all).

Latest Comments

1 2 3 4 5 6 Next › Last »

intelfx commented on 2017-01-08 01:55

@dlp: Arch packaging guidelines[1][2] suggest that `arch=()` array shall only contain architectures that are supported by Arch itself (i. e. i686 and x86_64).

[1]: https://wiki.archlinux.org/index.php/PKGBUILD#arch
[2]: https://wiki.archlinux.org/index.php/Arch_packaging_standards#Architectures

dlp commented on 2017-01-07 15:18

Could you please add the ARM architectures to the arch array in the PKGBUILD? At the time of writing, these are 'aarch64', 'arm', 'armv6h' and 'armv7h'. I have tested this on the armv7h architecture and it works perfectly. I can't see any reason why it won't work on the other variants, though I don't have the hardware to test.

hifistux commented on 2016-12-05 05:56

Works fine with HP Laser Jet 1020. Thanks intelfx!

intelfx commented on 2016-11-12 07:39

@dront78: This message comes from the upstream-provided Makefile. It should be harmless.

dront78 commented on 2016-11-12 07:36

could you tell what is
> Cannot read file foomatic-db/db/oldprinterids
during the installation process?

intelfx commented on 2016-11-12 03:37

Package bumped. New package foo2zjs-nigtly has been uploaded which has a `pkgver()` function that extracts the timestamp from the driver's home page.

This should eliminate the need for frequent checksum mismatches and bump requests (provided that the patches will still apply). Please use that package, I'll request this one to be merged.

lisu_ml commented on 2016-11-11 19:49

It still doesn't verify the sources properly:

=> Validating source files with sha256sums...
foo2zjs-20161105.tar.gz ... FAILED
0001-Makefile-DESTDIR-support.patch ... Passed
0002-Makefile-general-fixes.patch ... Passed
0003-Rework-firmware-loading.patch ... Passed
0004-Makefile-fix-generating-.ppd-in-place.patch ... Passed
0005-Makefile-leverage-default-rules-as-much-as-possible-.patch ... Passed
==> ERROR: One or more files did not pass the validity check!
==> ERROR: Makepkg was unable to build foo2zjs.

intelfx commented on 2016-11-08 14:52

@eMan.Lived Thanks for notifying, package bumped. You could use "Flag package out-of-date" to avoid flooding the comments.

intelfx commented on 2016-11-08 14:51

@bitsfritz Then I'm out of ideas. I do not have access to a supported printer now but I'll see if I can reproduce that as soon as I get there.

eMan.Lived commented on 2016-11-08 08:54

foo2zjs-20161021.tar.gz ... FAILED

After manually correct sha256sum

Hunk #15 FAILED at 1040.

It seems that 0002-Makefile-general-fixes.patch does not apply.