Warning: file_exists(): open_basedir restriction in effect. File(/srv/http/vhosts/aur.archlinux.org/public/web/locale//en/LC_MESSAGES/aurweb.mo) is not within the allowed path(s): (/srv/http/vhosts/aur-dev.archlinux.org/:/etc/aurweb/) in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/streams.php on line 90
AUR (en) - firmware-mod-kit

Notice: Undefined variable: name in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/pkgfuncs.inc.php on line 248

Package Details: firmware-mod-kit 0.99-7

Git Clone URL: https://aur-dev.archlinux.org/firmware-mod-kit.git (read-only)
Package Base: firmware-mod-kit
Description: Allows easy deconstruction and reconsutrction of firmware images for various embedded devices
Upstream URL: http://code.google.com/p/firmware-mod-kit/
Licenses: GPL
Submitter: antoniovazquez
Maintainer: anthraxx
Last Packager: anthraxx
Votes: 19
Popularity: 0.244514
First Submitted: 2013-05-30 12:23
Last Updated: 2016-10-20 22:46

Dependencies (3)

Required by (1)

Sources (1)

Latest Comments

1 2 Next › Last »

90torf commented on 2016-10-20 21:10

I got a 404 error while downloading the source file fmk_099.tar.gz.
Problem can be solved by changing source parameter:

source=('https://storage.googleapis.com/google-code-archive-downloads/v2/code.google.com/firmware-mod-kit/fmk_099.tar.gz')

seqizz commented on 2015-08-28 15:50

Strangely, building this with -march=native in makepkg.conf caused kernel panic on my laptop, -march=x86-64 is compiling fine. CPU is i7-5700HQ. native resolved to "broadwell" as march.

antoniovazquez commented on 2015-01-21 19:33

I'm sorry but I've never used Packer. I'm having a look at it. I encourage you to have a look at the FMK wiki and try to execute any of the executables this package contains.

https://code.google.com/p/firmware-mod-kit/wiki/Documentation?tm=6

jhe commented on 2015-01-18 18:47

i install binwalk with packer , does that mean i got this already ?

antoniovazquez commented on 2014-08-06 14:05

Thanks LKS. Updated!

lks commented on 2014-08-01 07:45

arch=('any') in PKGBUILD should be changed to arch=('i686' 'x86_64'). There is a difference between those types. 'any' meens that the final package must not have any platform/ architecture specific files. There serveral ELF-programs included in this package, e.g. /opt/firmware-mod-kit/src/addpattern so 'any' is not proposal.
lks

lks commented on 2014-08-01 07:40

arch=('any') in PKGBUILD should be changed to arch=('i686' 'x86_64'). There is a differenz between those types. 'any' meens that the final package must not have any platform/ architecture specific files. There serveral ELF-programs included in this package, e.g. /opt/firmware-mod-kit/src/addpattern.
lks

antoniovazquez commented on 2014-07-20 11:04

Done!

Thanks

Huulivoide commented on 2014-07-16 09:13

python2-magick in the repos is excatly the
same as file-python2 from AUR. Please update.

antoniovazquez commented on 2014-02-27 20:03

Re-re-reupdated. Thanks again!