Notice: Undefined variable: name in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/pkgfuncs.inc.php on line 248

Package Details: firefox-esr-privacy 45.4.0-1

Git Clone URL: https://aur-dev.archlinux.org/firefox-esr-privacy.git (read-only)
Package Base: firefox-esr-privacy
Description: Standalone web browser from mozilla.org
Upstream URL: https://www.mozilla.org/firefox/
Keywords: enhanced Firefox Privacy version
Licenses: GPL, MPL, LGPL
Conflicts: firefox
Provides: firefox
Submitter: Wilco
Maintainer: Wilco
Last Packager: Wilco
Votes: 8
Popularity: 0.031643
First Submitted: 2016-03-09 08:55
Last Updated: 2016-11-08 21:01

Required by (111)

Sources (12)

Latest Comments

1 2 3 Next › Last »

DaarkWel commented on 2016-11-15 17:43

> if there are more interested I might create non ESR patches

Yes it'd be nice.

Wilco commented on 2016-11-08 20:48

@Case_Of: no, the regular release often changes a lot, if there are more interested I might create non ESR patches

Case_Of commented on 2016-10-30 21:24

does the patch work on firefox main releases ?

cooljay032 commented on 2016-07-31 18:56

hi,successful build now with patches mozilla-1245076-1.patch and harfbuzz-1.1.3.patch.gz (from firefox-esr package)!
lars

Wilco commented on 2016-06-15 07:32

Don't know about the build error, it might be related to GCC 6. You can try to add the two patches from the Arch pkgbuild to fix building with GCC 6, see:

https://git.archlinux.org/svntogit/packages.git/tree/trunk/PKGBUILD?h=packages/firefox

Try to add the patches mozilla-1245076.patch and mozilla-1245076-1.patch

cooljay032 commented on 2016-06-14 21:53

same build error here with current version and up2date system! any solution?
regards,lars

Klyachkivsky commented on 2016-06-04 02:34

Previous version easily build and install , but it gives an error after 2-3 minutes to build .

make: *** [client.mk:171: build] Error 2
==> ERROR: A failure occurred in build().
Aborting...
==> ERROR: Makepkg was unable to build firefox-esr-privacy.
==> Restart building firefox-esr-privacy ? [y/N]
==> --------------------------------------------

Wilco commented on 2016-05-11 10:25

@Alad: thanks for noticing, updated the PKGBUILD

Alad commented on 2016-05-11 07:55

Please quote your srcdir variables so it doesn't break inside directories with spaces in them. Curly braces don't replace quotes in any way.

Klyachkivsky commented on 2016-05-10 10:58

Yes , I tried to install firefox-i18n-uk . Pacman but then offers to delete firefox-esr-privacy and wants to install firefox from the repository . I did pacman -Sdd and installed a language pack but I can not use it - it is not active . Very sorry that it happened .Your build works best on my weak laptop . Nevertheless thank you :)