Warning: file_exists(): open_basedir restriction in effect. File(/srv/http/vhosts/aur.archlinux.org/public/web/locale//en/LC_MESSAGES/aurweb.mo) is not within the allowed path(s): (/srv/http/vhosts/aur-dev.archlinux.org/:/etc/aurweb/) in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/streams.php on line 90
AUR (en) - filezillasecure

Notice: Undefined variable: name in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/pkgfuncs.inc.php on line 248

Package Details: filezillasecure 3.18.0-3

Git Clone URL: https://aur-dev.archlinux.org/filezillasecure.git (read-only)
Package Base: filezillasecure
Description: Fork of the well-known Filezilla client with password encryption
Upstream URL: http://filezillasecure.com/
Licenses: GPL
Conflicts: filezilla
Submitter: fordprefect
Maintainer: fordprefect
Last Packager: fordprefect
Votes: 1
Popularity: 0.188584
First Submitted: 2016-11-07 22:06
Last Updated: 2016-11-16 21:37

Latest Comments

ilikenwf commented on 2016-12-27 00:27

I really wish that the developer would provide this in a git repo...so that it could be synced with the base FZ tree, and allowed import of the old sitemanager file...

I'm fully encrypted so I don't bother using it but would if these were the case.

dx2 commented on 2016-11-17 23:03

If you're interested how this software packaging and building works under the hood: There is a good book about the building and packaging tools, called 'Autotools: A Practitioner's Guide to GNU Autoconf, Automake, and Libtool'

fordprefect commented on 2016-11-16 21:38

hi, thank you for your help! i didnt know about autoreconf, but that totally fixes it. also, added the conflict statement.

dx2 commented on 2016-11-15 08:40

it's 1.15

I had a look into it, the reason is the sed replacement. in makefile.in files version 1.14.1 is used and the sed command replaces only 1.14 to 1.15 resulting in 1.15.1

Running autoreconf before ./configure instead of the find/sed commands seems to correct the autoconf/automake scripts.

if filezilla is still installed it can be removed upon installation of filezilla-secure with
conflicts=("filezilla")
otherwise there will be an error of existing files.

fordprefect commented on 2016-11-14 09:43

@dx2: i cannot reproduce your error at the moment. what is your automake version (automake --version)? i am a bit bewildered by the occurence of 1.15.1, which does not even exist (yet).
will investigate further once home, thank you for reporting issues.

dx2 commented on 2016-11-14 08:14

Getting an error during build(). It seems automake needs to be rerun before because the script are done with a version that is newer than the one installed in arch linux:

configure.ac:5: error: version mismatch. This is Automake 1.15,
configure.ac:5: but the definition used by this AM_INIT_AUTOMAKE
configure.ac:5: comes from Automake 1.15.1. You should recreate
configure.ac:5: aclocal.m4 with aclocal and run automake again.
locales/Makefile.am:46: warning: '%'-style pattern rules are a GNU make extension
locales/Makefile.am:50: warning: '%'-style pattern rules are a GNU make extension
WARNING: 'automake-1.15' is probably too old.
You should only need it if you modified 'Makefile.am' or
'configure.ac' or m4 files included by 'configure.ac'.
The 'automake' program is part of the GNU Automake package:
<http://www.gnu.org/software/automake>
It also requires GNU Autoconf, GNU m4 and Perl in order to run:
<http://www.gnu.org/software/autoconf>
<http://www.gnu.org/software/m4/>
<http://www.perl.org/>
make: *** [Makefile:444: Makefile.in] Error 1
==> ERROR: A failure occurred in build().
Aborting...
==> ERROR: Makepkg was unable to build filezillasecure.