Warning: file_exists(): open_basedir restriction in effect. File(/srv/http/vhosts/aur.archlinux.org/public/web/locale//en/LC_MESSAGES/aurweb.mo) is not within the allowed path(s): (/srv/http/vhosts/aur-dev.archlinux.org/:/etc/aurweb/) in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/streams.php on line 90
AUR (en) - ffmpeg-full

Notice: Undefined variable: name in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/pkgfuncs.inc.php on line 248

Package Details: ffmpeg-full 1:3.2.2-1

Git Clone URL: https://aur-dev.archlinux.org/ffmpeg-full.git (read-only)
Package Base: ffmpeg-full
Description: Complete solution to record, convert and stream audio and video (with all options)
Upstream URL: http://ffmpeg.org/
Licenses: GPL3, custom:unredistributable
Conflicts: ffmpeg, ffmpeg-full-git, ffmpeg-git
Provides: ffmpeg, libavcodec.so, libavdevice.so, libavfilter.so, libavformat.so, libavresample.so, libavutil.so, libpostproc.so, libswresample.so, libswscale.so
Submitter: rpolzer
Maintainer: isiachi
Last Packager: isiachi
Votes: 57
Popularity: 1.421754
First Submitted: 2013-01-24 11:17
Last Updated: 2016-12-07 22:27

Dependencies (87)

Required by (539)

Sources (4)

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 9 10 11 ... Next › Last »

piratejon commented on 2015-01-02 19:02

To answer my own question I found http://unix.stackexchange.com/questions/111302/difference-between-tar-gz-asc-git-tar-bz2-and-tar-bz2 and just had to do this:

gpg --keyserver x-hkp://pool.sks-keyservers.net --recv-keys 0xD67658D8

to get it to work.

The argument for --recv-keys was found by trying to verify manually: gpg --verify ffmpeg-2.5.2.tar.bz2.asc.

piratejon commented on 2015-01-01 02:04

Can I find or import this public key? How would I go about doing that?

==> Verifying source file signatures with gpg...
ffmpeg-2.5.2.tar.bz2 ... FAILED (unknown public key B4322F04D67658D8)
==> ERROR: One or more PGP signatures could not be verified!

isiachi commented on 2014-12-31 13:17

Thanks PyroDevil

Updated.

Eriner commented on 2014-12-30 11:22

To anyone else facing the package signature issue, it seems to be a phenomanon recently among many packeges. Importing the PGP key manually fixes the problem. DO NOT SIGN THE KEYS.

gpg --keyserver pgp.mit.edu --recv-keys D67658D8

Eriner commented on 2014-12-30 11:08

==> Verifying source file signatures with gpg...
ffmpeg-2.5.2.tar.bz2 ... FAILED (unknown public key B4322F04D67658D8)
==> ERROR: One or more PGP signatures could not be verified!

PyroDevil commented on 2014-12-29 11:17

For decklink you need decklink-sdk and set the CFLAGS to include the source directory before the configure step.

I succeeded doing it with the ffmpeg-full-extra package here:
https://gist.github.com/anonymous/d9a5e02b011c07b9dfab

isiachi commented on 2014-10-13 17:17

A simple solution is:
remove ffmpeg-full only:
#pacman -Rdd ffmpeg-full
then do the update
#pamcna -Syu
then recompile the new version of ffmpeg-full:
$yaourt -S ffmpeg-full (or any other aur helper)

The one proposed by moore_cr is good too.

moore_cr commented on 2014-10-12 23:39

Here's how I solved this issue (I use yaourt). I think the problem is that you're not allowed to remove libvidstab-git because it's still a dependency of the currently-installed ffmpeg-full:
1) Remove libvidstab-git even though it's a dependency for the current ffmpeg-full
yaourt -Rdd libvidstab-git
2) Install vid.stab
yaourt -S vid.stab
3) Upgrade ffmpeg-full
yaourt -S ffmpeg-full

I followed these steps, but you can probably skip 2) since it would be installed automatically as a dependency.

colinkeenan commented on 2014-10-10 15:34

libvidstab-git is not listed as a dependency anymore, but it still requires it. I'm not sure what's wrong, but I can't install this update.

colinkeenan commented on 2014-10-10 15:32

==> Continue building ffmpeg-full ? [Y/n]
==> -------------------------------------
==>
==> Building and installing package
==> Install or build missing dependencies for ffmpeg-full:
resolving dependencies...
looking for inter-conflicts...
:: vid.stab and libvidstab-git are in conflict. Remove libvidstab-git? [y/N] y
error: failed to prepare transaction (could not satisfy dependencies)
:: ffmpeg-full: requires libvidstab-git
==> Restart building ffmpeg-full ? [y/N]
==> ------------------------------------
==>