Warning: file_exists(): open_basedir restriction in effect. File(/srv/http/vhosts/aur.archlinux.org/public/web/locale//en/LC_MESSAGES/aurweb.mo) is not within the allowed path(s): (/srv/http/vhosts/aur-dev.archlinux.org/:/etc/aurweb/) in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/streams.php on line 90
AUR (en) - ffmpeg-full-nvenc

Notice: Undefined variable: name in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/pkgfuncs.inc.php on line 248

Package Details: ffmpeg-full-nvenc 1:3.2.2-7

Git Clone URL: https://aur-dev.archlinux.org/ffmpeg-full-nvenc.git (read-only)
Package Base: ffmpeg-full-nvenc
Description: Record, convert, and stream audio and video (all codecs including Nvidia NVENC)
Upstream URL: http://ffmpeg.org/
Keywords: ffmpeg
Licenses: GPL, custom:unredistributable
Conflicts: ffmpeg, ffmpeg-full, ffmpeg-full-extra, ffmpeg-full-git, ffmpeg-git
Provides: ffmpeg, libavcodec.so, libavdevice.so, libavfilter.so, libavformat.so, libavresample.so, libavutil.so, libpostproc.so, libswresample.so, libswscale.so, qt-faststart
Submitter: dark-saber
Maintainer: dark-saber
Last Packager: dark-saber
Votes: 17
Popularity: 1.319873
First Submitted: 2015-08-04 08:01
Last Updated: 2016-12-26 13:15

Dependencies (85)

Required by (538)

Sources (4)

Latest Comments

« First ‹ Previous ... 4 5 6 7 8 9

dark-saber commented on 2016-01-21 17:18

Fixed it, thanks!

Anonymous comment on 2016-01-20 21:10

A temporary(?) workaround is to :
export CFLAGS+=" -I/usr/include/nvidia-sdk"
before ./configure in build

thesbros commented on 2016-01-20 21:06

`
==> Starting build()...
==> Starting configure...
ERROR: nvEncodeAPI.h not found.

If you think configure made a mistake, make sure you are using the latest
version from Git. If the latest version fails, report the problem to the
ffmpeg-user@ffmpeg.org mailing list or IRC #ffmpeg on irc.freenode.net.
Include the log file "config.log" produced by configure as this will help
solve the problem.
==> ERROR: A failure occurred in build().
`

Got this after updating.

epitron commented on 2016-01-03 22:50

The OpenCL dependency seems to be missing:

==> Extracting sources...
-> Extracting ffmpeg-2.8.4.tar.bz2 with bsdtar
==> Starting build()...
==> Starting configure...
ERROR: opencl not found

I had to install it by hand.

Anonymous comment on 2015-12-29 09:55

No problem on my PC.
Did you try to compile the latest libutvideo-git again?
Did you compile it since the C++ ABI change : https://www.archlinux.org/news/c-abi-change/ ?

Commander commented on 2015-12-29 03:39

Is it only me this doesn't want to build with --libutvideo ?

Anonymous comment on 2015-11-28 12:20

Hi,

I don't know if it is related, but with cuda package installed I got warning in ffmpeg and error with other programs.
Seems ffmpeg try to load /opt/cuda/lib64/libOpenCL.so instead of /usr/lib/libnvidia-opencl.so.

dark-saber commented on 2015-11-28 07:37

Hi,
Last time I checked ffmpeg with enabled openCL broke building of some other packages, so I disabled it. I'll test it more to determine whether to re-enable it.

Thank you!

Anonymous comment on 2015-11-28 06:07

Hi,

in description you wrote openCL is enabled, but in PKGBUILD the --enable-opencl for configure is missing.
Is it an oversight?