Warning: file_exists(): open_basedir restriction in effect. File(/srv/http/vhosts/aur.archlinux.org/public/web/locale//en/LC_MESSAGES/aurweb.mo) is not within the allowed path(s): (/srv/http/vhosts/aur-dev.archlinux.org/:/etc/aurweb/) in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/streams.php on line 90
AUR (en) - feedreader-git

Notice: Undefined variable: name in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/pkgfuncs.inc.php on line 248

Package Details: feedreader-git 1.6.2.r1672.b538ade-2

Git Clone URL: https://aur-dev.archlinux.org/feedreader-git.git (read-only)
Package Base: feedreader-git
Description: FeedReader is a modern desktop application designed to complement existing web-based RSS accounts.
Upstream URL: https://github.com/jangernert/FeedReader
Keywords: atom feed feedreader reader rss tt-rss
Licenses: GPL3
Conflicts: feedreader
Provides: feedreader
Submitter: horosgrisa
Maintainer: horosgrisa
Last Packager: horosgrisa
Votes: 13
Popularity: 0.502024
First Submitted: 2016-02-04 17:35
Last Updated: 2017-01-31 18:11

Latest Comments

1 2 3 Next › Last »

arjan5 commented on 2017-01-31 10:10

Having the same issues as @Markiz. Adding -DCMAKE_INSTALL_LIBDIR=/usr/lib to the cmake command fixes that. FeedReader changed their build process a bit, after which they started installing in /usr/lib64 instead of /usr/lib.

Markiz commented on 2017-01-30 04:01

error: it wasn't succeeded to finish transaction (the clashing files)
feedreader-git: '/usr/lib64' exists in file system
Errors are noticed, packets aren't updated.

horosgrisa commented on 2016-12-14 09:53

@dsboger Fixed

dsboger commented on 2016-12-13 14:50

I've pasted a fixed PKGBUILD in http://pastebin.com/y8RQd7jC. One last issue I forgot before was missing git in makedeps.

dsboger commented on 2016-12-13 13:26

Hello. I'd like to suggest a few fixes/improvements to this package:

(i) The install file is no longer necessary. Pacman handles the icon cache and schema generation automatically via hooks.

(ii) The cmake options USE_WEBKIT_4 and WITH_LIBUNITY are no longer necessary for builds from master (https://github.com/jangernert/FeedReader/issues/254#issuecomment-257886063).

(iii) FeedReader depends on gnome-online-accounts, not gvfs-goa.

(iv) It is missing a dep on curl.

(v) The version calculated in the pkgver() function is not correct. The problem is that latest stable version (1.6.2) was tagged in a "stable" branch upstream, so latest tag is not reachable from "master". I don't know how to solve that automatically, but it could use a mix of a manually set version (1.6.2) followed by the method for a repo without tags as recommended by https://wiki.archlinux.org/index.php/VCS_package_guidelines#Git.

I'll sketch these changes and send you a patch-set. Thanks for your efforts!

archcid commented on 2016-09-28 21:33

The package is going to release feedreader-git-1.6.1.r210.g2d8c9ae-1. Recursive update.

JeanLuc commented on 2016-09-27 02:44

There seems to be an issue with the local-rss-backend and this AUR package:
https://github.com/jangernert/FeedReader/issues/213

vivaeltopo commented on 2016-09-26 19:34

you have commas in the dependency list that let (atleast yaourt) the build process fail.

ymermoud commented on 2016-09-05 16:13

please add libpeas and gvfs-goa as dependencies

horosgrisa commented on 2016-09-01 18:41

@asonix Please, create issue at https://github.com/jangernert/FeedReader