Warning: file_exists(): open_basedir restriction in effect. File(/srv/http/vhosts/aur.archlinux.org/public/web/locale//en/LC_MESSAGES/aurweb.mo) is not within the allowed path(s): (/srv/http/vhosts/aur-dev.archlinux.org/:/etc/aurweb/) in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/streams.php on line 90
AUR (en) - evince-git

Notice: Undefined variable: name in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/pkgfuncs.inc.php on line 248

Package Details: evince-git 3.17.2.r15.gb998a03-1

Git Clone URL: https://aur-dev.archlinux.org/evince-git.git (read-only)
Package Base: evince-git
Description: Simply a document viewer
Upstream URL: http://projects.gnome.org/evince/
Licenses: GPL
Conflicts: evince
Provides: evince
Submitter: maurofruet
Maintainer: archdria
Last Packager: archdria
Votes: 3
Popularity: 0.000005
First Submitted: 2012-10-28 19:53
Last Updated: 2015-07-15 17:44

Required by (10)

Sources (2)

Latest Comments

1 2 Next › Last »

archdria commented on 2015-10-04 13:08

@craeckie: since the PKGBUILD has a pkgver() function, the version is updated automagically when you build it, so there's no need to update the PKDGBUILD for every git commit.

craeckie commented on 2015-10-04 12:33

current version: 3.18.0.r30.g696d1b5-1

Akseli0x61 commented on 2014-08-07 17:45

Dependencies needed:


foobarrior commented on 2014-08-07 05:44

Please add adwaita-icon-theme-git to dependencies

efernandes commented on 2014-02-03 21:57

PKGBUILD updated :)

wil93 commented on 2014-02-02 23:32

It seems that the bug with automake 1.13 ([1]) has been solved (I just successfully built the package using automake 1.14). I think that the "<1.13" string can be now removed from the dependencies.

[1] https://bugs.archlinux.org/task/33285

rafaelff commented on 2013-03-02 16:37

@maurofruet: That's expected. Running "pacman -Q gtk3" will show you that you have gtk+ version 3.6.4, which is what Archlinux provides at the moment. GNOME is somewhat close to release a new version (probably March 25 [1] ) and this requirement will be fulfilled.

[1] https://live.gnome.org/ThreePointSeven

maurofruet commented on 2013-03-02 14:58

It doesn't work for me. I get the following error:

checking for LIBDOCUMENT... no
configure: error: Package requirements (gtk+-3.0 >= 3.7.5 gio-2.0 >= 2.33.2 gmodule-no-export-2.0 >= 2.33.2 gmodule-2.0) were not met:

Requested 'gtk+-3.0 >= 3.7.5' but version of GTK+ is 3.6.4

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables LIBDOCUMENT_CFLAGS
and LIBDOCUMENT_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

rafaelff commented on 2013-03-01 21:03

yep, gnome-common currently doesn't support automake 1.13. For more information, see https://bugs.archlinux.org/task/33285

I think the easier solution, for now, is to add automake-1-12 as makedependency. It works just fine.

maurofruet commented on 2013-03-01 20:53

You're right, gtk-doc is missing as make dependency, as well as gnome-common.
I don't get why the leading slash should be removed: I've read many PKGBUILDs of Gnome packages in the extra repository, but none of them is without the leading slash. I think that the error is in the wiki (no updates for a lot of months).
However, even after adding the new make dependencies, I can't compile the package. What about you?
I get an error with automake because of a bug of automake 1.13, which can be temporarily fixed by adding:
before running ./autogen
To compile, evince still requires newer versions of some packages, including gtk3 >= 3.7.5, but the version currently present in testing is 3.6.4 and gtk3-git has been flagged out-of-date.