Warning: file_exists(): open_basedir restriction in effect. File(/srv/http/vhosts/aur.archlinux.org/public/web/locale//en/LC_MESSAGES/aurweb.mo) is not within the allowed path(s): (/srv/http/vhosts/aur-dev.archlinux.org/:/etc/aurweb/) in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/streams.php on line 90
AUR (en) - elm-platform

Notice: Undefined variable: name in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/pkgfuncs.inc.php on line 248

Package Details: elm-platform 0.18.0-1

Git Clone URL: https://aur-dev.archlinux.org/elm-platform.git (read-only)
Package Base: elm-platform
Description: Bundle of all core development tools for the Elm language.
Upstream URL: http://elm-lang.org
Licenses: BSD3
Conflicts: nodejs-elm
Submitter: Luchs
Maintainer: Luchs
Last Packager: Luchs
Votes: 8
Popularity: 0.354579
First Submitted: 2015-11-20 13:48
Last Updated: 2016-11-14 15:54

Latest Comments

« First ‹ Previous 1 2

dave_v commented on 2016-06-07 07:07

The build failed for me. Had to add "--force-reinstalls" to the cabal install calls to get it working again. Can you patch the PKGBUILD to do this? Cheers

Luchs commented on 2016-05-11 17:33

No clue about that error, sorry. You could try again now with 0.17 or alternatively install the binaries from node.js. (Sorry, I forgot about your comment.)

mzimmerman commented on 2016-02-06 14:48

Had an error trying to build this: (no experience with elm)

Packages configured successfully!
elm-make: elm-stuff/packages/elm-lang/core/3.0.0/src/Graphics/Element.elm: hGetContents: invalid argument (invalid byte sequence)
elm-make: thread blocked indefinitely in an MVar operation

Custom build step: creating and collecting all static resources
cabal: Error: some packages failed to install:
elm-reactor-0.16 failed during the building phase. The exception was:
ExitFailure 1
==> ERROR: A failure occurred in build().
Aborting...

Luchs commented on 2015-11-27 23:36

I updated the checksums. Apparently, upstream did some fixes and reused the 0.16 tag for those repositories.

xificurC commented on 2015-11-27 22:24

Checksums are failing for me:
==> Validating source files with sha256sums...
elm-compiler.zip ... FAILED
elm-package.zip ... Passed
elm-make.zip ... FAILED
elm-reactor.zip ... FAILED
elm-repl.zip ... Passed