Warning: file_exists(): open_basedir restriction in effect. File(/srv/http/vhosts/aur.archlinux.org/public/web/locale//en/LC_MESSAGES/aurweb.mo) is not within the allowed path(s): (/srv/http/vhosts/aur-dev.archlinux.org/:/etc/aurweb/) in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/streams.php on line 90
AUR (en) - efl-git

Notice: Undefined variable: name in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/pkgfuncs.inc.php on line 248

Package Details: efl-git 1.18.0beta1.49353.g4352747-1

Git Clone URL: https://aur-dev.archlinux.org/efl-git.git (read-only)
Package Base: efl-git
Description: Enlightenment Foundation Libraries - Development version
Upstream URL: http://www.enlightenment.org
Licenses: GPL2, custom, BSD, LGPL2.1
Conflicts: efl, elementary, elementary-git, elementary_test, elementary_test-git, evas_generic_loaders, evas_generic_loaders-git
Provides: efl=1.18.0beta1.49353.g4352747, elementary=1.18.0beta1.49353.g4352747, elementary-git=1.18.0beta1.49353.g4352747, evas_generic_loaders=1.18.0beta1.49353.g4352747
Submitter: Scimmia
Maintainer: None
Last Packager: Scimmia
Votes: 82
Popularity: 0.501545
First Submitted: 2013-02-15 10:00
Last Updated: 2016-07-30 13:46

Dependencies (37)

Required by (48)

Sources (1)

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 9 10 ... Next › Last »

Scimmia commented on 2013-08-05 14:50

pkgver/pkgrel bump for poppler soname bump.

Scimmia commented on 2013-08-01 14:30

Bumped pkgver/pkgrel because of giflib soname bump. I also synced a few things to upstream, including enabling the webp loader.

Scimmia commented on 2013-06-19 21:27

pkgrel bump for libraw soname bump + a few changes from upstream.

Scimmia commented on 2013-06-08 04:48

Big changes. Raster added a PKGBUILD to Elementary, so I'm keeping up with the way upstream wants things built.

The big one is that the test app is split out into a separate package. You'll also notice that the final packages are much smaller; somehow I missed that this was building static libs.

Scimmia commented on 2013-06-04 20:17

Update deps, this needs the gstreamer 'plugin' packages in order to create thumnails for EFM.

Scimmia commented on 2013-06-04 20:11

Evas' wayland_egl engine had to be disabled. It was rewritten to use gl_common, and since everything's now common, it's either all OpenGL or GLES, it can't be both. The wayland_shm engine is still available for those that want it.

Deps changed in that I learned that Emotion only needs the gstreamer lib packages, not the "plugin" packages. It's actually evas_generic_loaders that need those.

I also removed all of the "provides" for the old individual -svn packages. Everything should be up to date now to either depend on release or on efl-git.

Scimmia commented on 2013-05-25 11:20

pkgrel bump for poppler soname bump.

Scimmia commented on 2013-05-06 22:33

pkgrel bump because of libpng soname bump. This needs to be rebuilt against the new version.

fsckd commented on 2013-05-01 13:36

> [...] I'll do most of them now and hold off on efl-git until the libpng soname bump causes a pkgrel bump.

awesome great :D

Scimmia commented on 2013-04-30 20:05

abarbarian, that means you need to update efl-git.