Notice: Undefined variable: name in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/pkgfuncs.inc.php on line 248

Package Details: dosbox-x-git 1893.014b5f9-2

Git Clone URL: https://aur-dev.archlinux.org/dosbox-x-git.git (read-only)
Package Base: dosbox-x-git
Description: x86 emulator with builtin DOS, with patches with more features
Upstream URL: http://dosbox.sourceforge.net
Licenses: GPL
Submitter: Minerva.W
Maintainer: Minerva.W
Last Packager: Minerva.W
Votes: 4
Popularity: 0.077283
First Submitted: 2015-10-19 03:47
Last Updated: 2016-10-08 16:27

Latest Comments

aaronp commented on 2016-09-05 07:54

The default executable name is dosbox-x now. You should be able to change the sysconfdir and the desktop file and allow dosbox-x to be parallel installable with vanilla dosbox.

TruckerZer0 commented on 2016-06-02 09:00

Thank you very much!

Minerva.W commented on 2016-04-23 02:20

Hi @TruckerZer0 @aaronp

The patch has applied and the problem seems to be solved so far.

TruckerZer0 commented on 2016-03-25 00:39

Thank you!

aaronp commented on 2016-03-20 23:41

https://github.com/joncampbell123/dosbox-x/issues/184

TruckerZer0 commented on 2016-03-11 07:09

It gives me this error:

In file included from fpu.cpp:45:0:
fpu_instructions.h: In function ‘void FPU_FCOM(Bitu, Bitu)’:
fpu_instructions.h:394:27: error: ‘isinf’ was not declared in this scope
if (isinf(fpu.regs[st].d) && isinf(fpu.regs[other].d)) {
^
fpu_instructions.h:394:27: note: suggested alternative:
In file included from fpu_instructions.h:283:0,
from fpu.cpp:45:
/usr/include/c++/5.3.0/cmath:621:5: note: ‘std::isinf’
isinf(_Tp __x)
^
Makefile:345: set di istruzioni per l'obiettivo "fpu.o" non riuscito
make[3]: *** [fpu.o] Errore 1

chrisq commented on 2015-12-03 13:29

Joystick support seems broken for me.
It is not detected, but other dosbox binaries detects as normal.
Do you know if it a problem upstream or this build?

spider-mario commented on 2015-10-29 13:05

Shouldn’t `makedepends` contain git rather than subversion?

Minerva.W commented on 2015-10-29 01:57

@Cork

Updated.

Cork commented on 2015-10-24 22:28

The package munt-git doesn't exist anymore, should prob just use munt instead.