Warning: file_exists(): open_basedir restriction in effect. File(/srv/http/vhosts/aur.archlinux.org/public/web/locale//en/LC_MESSAGES/aurweb.mo) is not within the allowed path(s): (/srv/http/vhosts/aur-dev.archlinux.org/:/etc/aurweb/) in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/streams.php on line 90
AUR (en) - dolfin-git

Notice: Undefined variable: name in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/pkgfuncs.inc.php on line 248

Package Details: dolfin-git 20151005-1

Git Clone URL: https://aur-dev.archlinux.org/dolfin-git.git (read-only)
Package Base: dolfin-git
Description: the C++/Python interface of FEniCS, providing a consistent PSE (Problem Solving Environment) for ordinary and partial differential equations.
Upstream URL: https://bitbucket.org/fenics-project/dolfin
Licenses: LGPL
Groups: fenics-git
Conflicts: dolfin
Submitter: myles
Maintainer: myles
Last Packager: myles
Votes: 7
Popularity: 0.000410
First Submitted: 2013-03-22 22:40
Last Updated: 2015-11-19 23:30

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 Next › Last »

TSPMP commented on 2015-03-23 13:44

@hme Can confirm. I needed to install python2-sympy to build the package, too.

hme commented on 2015-02-03 19:16

Install wont complete unless you have
python2-sympy
Should it be listed as a dependency?

simul commented on 2014-07-26 10:16

After installing dolfin-git without errors, I now get the following error when I try to run the demos:

In instant.recompile: The module did not compile with command 'make VERBOSE=1'

Any clues?

myles commented on 2014-07-08 20:06

@gasagna: quite right, I have corrected it (back to what it used to be)

gasagna commented on 2014-07-07 16:11

Apparently installing dolfin-git fails on my computer with

==> Building and installing package
==> Install or build missing dependencies for dolfin-git:
error: target not found: instant
error: target not found: ffc
==> Restart building dolfin-git ? [y/N]

However, installing instant-git and ffc-git solves this issue. Can it be automated somehow?

Thanks for the package.

ben_hutchings commented on 2014-06-09 18:34

Trying to run makepkg, failure occurs in build()

CMake Error at CMakeLists.txt:291
Could not find a configuration file for package UFC that is compatible with he requested version 1.4.0

myles commented on 2014-04-24 21:14

@sparkinson ufc has been merged into ffc so I need to update this package (and ffc-git), in the meantime I'll flag it out of date

sparkinson commented on 2014-04-20 14:20

I just tried to install this. I can't find ufc-git? I found a message saying that it had been incorporated into dolfin-git. If that is the case, can it be removed from the dependencies?

davidovitch commented on 2014-02-05 22:08

I think cppunit from [extra] should be a (build) dependency since it the build failed for me without it.

aradan_d commented on 2014-01-27 21:17

Is PETSC necessary? I could install dolfin, but when building it I got:

-- The following optional packages were found:
-- -------------------------------------------
-- (OK) OPENMP
-- (OK) MPI
-- (OK) TRILINOS
-- (OK) PARMETIS
-- (OK) CGAL
-- (OK) ZLIB
-- (OK) PYTHON
-- (OK) VTK
-- (OK) QT
--
-- The following optional packages were not found:
-- -----------------------------------------------
-- (**) PETSC
-- (**) PETSC4PY
-- (**) SLEPC
-- (**) TAO
-- (**) UMFPACK
-- (**) CHOLMOD
-- (**) PASTIX
-- (**) SCOTCH
-- (**) SPHINX
-- (**) HDF5

Even tough I have PETSC, SPHINX, SLEPC installed.