Warning: file_exists(): open_basedir restriction in effect. File(/srv/http/vhosts/aur.archlinux.org/public/web/locale//en/LC_MESSAGES/aurweb.mo) is not within the allowed path(s): (/srv/http/vhosts/aur-dev.archlinux.org/:/etc/aurweb/) in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/streams.php on line 90
AUR (en) - docker-git

Package Details: docker-git 1:1.14.0.dev.30065.a331056268-1

Git Clone URL: https://aur-dev.archlinux.org/docker-git.git (read-only)
Package Base: docker-git
Description: Pack, ship and run any application as a lightweight container.
Upstream URL: https://github.com/docker/docker
Keywords: cgroups container lxc
Licenses: Apache License Version 2.0
Conflicts: docker
Provides: docker
Submitter: ido
Maintainer: ido (flaccid)
Last Packager: flaccid
Votes: 39
Popularity: 1.604060
First Submitted: 2013-12-05 18:13
Last Updated: 2016-12-30 01:03

Required by (37)

Sources (2)

Latest Comments

1 2 3 4 5 6 Next › Last »

flaccid commented on 2017-01-27 23:50

@ArgylePwnage -git packages use the master branch by default which is 1.14 in dev.

ArgylePwnage commented on 2017-01-27 23:47

Any chance this will get updated to 1.13?

flaccid commented on 2017-01-24 00:11

@Vi0L0 you'd need to take the issue upstream to docker. Unless we have an issue with the packaging here, nothing we can do - master branch is basically dev.

Vi0L0 commented on 2017-01-23 21:34

Built it today for a first time.
After systemctl start docker it wasn't able to start, it was "activating", but never finished, with last line: "containerd: flag provided but not defined: -l"
Using containerd instead of containerd-git would help to start docker but then docker itself doesn't work with error like:
"flag provided but not defined: -console
docker: Error response from daemon: oci runtime error: flag provided but not defined: -console."
Did you guys manage to make it work?

flaccid commented on 2016-11-06 08:59

This package uses master branch which could have bugs anytime and i686 is not supported much anymore upstream.

dluciv commented on 2016-11-06 08:36

Actually, my reason for using this package was not using git snapshot, but just running docker on x86 machine. This package was only one working for me =).

What helped me a lot:

1. I got oficial package from https://git.archlinux.org/svntogit/community.git/tree/trunk?h=packages/docker

2. Added i686 to architecture list

3. makepkg && install it

4. Looks working

flaccid commented on 2016-11-05 21:45

@dluciv looks like upstream issue.

dluciv commented on 2016-11-05 19:10

On x86:

docker: Error response from daemon: transport is closing.

and then, after some time

docker: Error response from daemon: grpc: the connection is unavailable.

flaccid commented on 2016-11-03 22:36

@inphinity removed. I guess we package docker-proxy separately now?

inphinity commented on 2016-11-03 16:23

Build is broken:
docker-proxy isn't being built with ./hack make.sh dynbinary anymore, which in turn breaks the docker binary from working:

==> Entering fakeroot environment...
==> Starting package()...
install: cannot stat 'bundles/1.13.0-dev/dynbinary-daemon/docker-proxy-1.13.0-dev': No such file or directory
==> ERROR: A failure occurred in package().
Aborting...

Changes from: https://github.com/docker/docker/commit/3996975b0840033bda3919440d122d734a4bc66b