Warning: file_exists(): open_basedir restriction in effect. File(/srv/http/vhosts/aur.archlinux.org/public/web/locale//en/LC_MESSAGES/aurweb.mo) is not within the allowed path(s): (/srv/http/vhosts/aur-dev.archlinux.org/:/etc/aurweb/) in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/streams.php on line 90
AUR (en) - devscripts

Notice: Undefined variable: name in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/pkgfuncs.inc.php on line 248

Package Details: devscripts 2.16.12-2

Git Clone URL: https://aur-dev.archlinux.org/devscripts.git (read-only)
Package Base: devscripts
Description: Scripts to make the life of a Debian Package maintainer easier
Upstream URL: http://packages.qa.debian.org/d/devscripts.html
Licenses: GPL2
Submitter: Misery
Maintainer: ItachiSan
Last Packager: ItachiSan
Votes: 18
Popularity: 0.383704
First Submitted: 2008-03-19 22:52
Last Updated: 2016-12-14 14:41

Dependencies (18)

Sources (2)

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 Next › Last »

Felixoid commented on 2014-11-25 16:59

devscripts_2.14.10.tar.xz 9ba9428a520781c5779ff69a2df0dab7

Sanao commented on 2014-09-03 16:11

A new version is available : 2.14.6 with this md5sum : 3040c0271f700e147188a524038c9ad1

jorge_barroso commented on 2014-07-16 18:25

md5sum for 2.14.5 is ('5271ab6e12349865dd7ab686f1010808')

Xenopathic commented on 2014-06-24 18:54

New version: 2.14.5

Alad commented on 2014-05-31 11:59

New version: 2.14.3
Fixed link: http://ftp.de.debian.org/debian/pool/main/d/devscripts/devscripts_2.14.3.tar.xz

pluc commented on 2014-01-29 11:22

Hi, I have two errors :

404 not found on the source, so I got this one :
http://ftp.de.debian.org/debian/pool/main/d/devscripts/devscripts_2.13.4~bpo70+1.tar.xz

(the difference is the "~bpo70+1" after the pkg version)

And couldn't find po4a (don't know if it's about my particular setup).

So I replaced 's|po4a|/usr/bin/vendor_perl/po4a|g' in po4a/Makefile

LordAro commented on 2013-09-17 10:18

ok, no it doesn't, but i have raised the issue upstream

LordAro commented on 2013-09-16 18:35

hi, any chance of an update to 2.12.6 ? (http://packages.qa.debian.org/d/devscripts.html)

It might help fix the errors below

Sanao commented on 2013-06-24 13:52

I can't build the package with this error :

pod2man --utf8 --center=" " --release="Debian Utilities" transition-check.pl > transition-check.1
transition-check.pl around line 66: Expected text after =item, not a number
POD document had syntax errors at /usr/bin/core_perl/pod2man line 71.
make[1]: *** [transition-check.1] Error 255
rm dd-list.tmp checkbashisms.tmp namecheck.tmp cvs-debrelease.tmp debchange.tmp mk-build-deps.tmp archpath.tmp dget.tmp build-rdeps.tmp cvs-debi.tmp cowpoke.tmp wnpp-check.tmp getbuildlog.tmp debrelease.tmp debrsign.tmp tagpending.tmp debcommit.tmp bts.tmp dcmd.tmp dscverify.tmp debi.tmp rc-alert.tmp rmadison.tmp list-unreleased.tmp cvs-debuild.tmp debsnap.tmp plotchangelog.tmp nmudiff.tmp manpage-alert.tmp dpkg-genbuilddeps.tmp chdist.tmp mergechanges.tmp debuild.tmp debcheckout.tmp mass-bug.tmp who-uploads.tmp diff2patches.tmp transition-check.tmp annotate-output.tmp whodepends.tmp pts-subscribe.tmp wnpp-alert.tmp uupdate.tmp debclean.tmp debsign.tmp licensecheck.tmp dcontrol.tmp desktop2menu.tmp debdiff.tmp debpkg.tmp uscan.tmp svnpath.tmp deb-reversion.tmp grep-excuses.tmp dpkg-depcheck.tmp
make[1]: Leaving directory `/home/alain/AUR/devscripts/src/devscripts-2.10.69+squeeze4/scripts'
make: *** [make_scripts] Error 2
==> ERROR: A failure occurred in build().
Aborting...

After modified items like this :

--- transition-check.pl.old 2013-06-24 15:35:36.728357161 +0200
+++ transition-check.pl 2013-06-24 15:35:06.405175102 +0200
@@ -58,12 +58,12 @@ be involved in a transition.

=over 4

-=item 0
+=item toto

Either B<--help> or B<--version> was used, or none of the packages examined
was involved in a transition.

-=item 1
+=item titi

At least one package examined is involved in a current transition.

I have a new error :

po4a --previous --no-backups devscripts-po4a.conf
'tempfile' can't be called as a method at /usr/share/perl5/vendor_perl/Locale/Po4a/Po.pm line 575.
make[1]: *** [translate] Error 255
make[1]: Leaving directory `/home/alain/AUR/devscripts/src/devscripts-2.10.69+squeeze4/po4a'
make: *** [translated_manpages] Error 2
==> ERROR: A failure occurred in build().
Aborting...

I can't solve this error.

Sanao commented on 2013-06-24 13:38

I can't build the package with this error :

pod2man --utf8 --center=" " --release="Debian Utilities" transition-check.pl > transition-check.1
transition-check.pl around line 66: Expected text after =item, not a number
POD document had syntax errors at /usr/bin/core_perl/pod2man line 71.
make[1]: *** [transition-check.1] Error 255
rm dd-list.tmp checkbashisms.tmp namecheck.tmp cvs-debrelease.tmp debchange.tmp mk-build-deps.tmp archpath.tmp dget.tmp build-rdeps.tmp cvs-debi.tmp cowpoke.tmp wnpp-check.tmp getbuildlog.tmp debrelease.tmp debrsign.tmp tagpending.tmp debcommit.tmp bts.tmp dcmd.tmp dscverify.tmp debi.tmp rc-alert.tmp rmadison.tmp list-unreleased.tmp cvs-debuild.tmp debsnap.tmp plotchangelog.tmp nmudiff.tmp manpage-alert.tmp dpkg-genbuilddeps.tmp chdist.tmp mergechanges.tmp debuild.tmp debcheckout.tmp mass-bug.tmp who-uploads.tmp diff2patches.tmp transition-check.tmp annotate-output.tmp whodepends.tmp pts-subscribe.tmp wnpp-alert.tmp uupdate.tmp debclean.tmp debsign.tmp licensecheck.tmp dcontrol.tmp desktop2menu.tmp debdiff.tmp debpkg.tmp uscan.tmp svnpath.tmp deb-reversion.tmp grep-excuses.tmp dpkg-depcheck.tmp
make[1]: Leaving directory `/home/alain/AUR/devscripts/src/devscripts-2.10.69+squeeze4/scripts'
make: *** [make_scripts] Error 2
==> ERROR: A failure occurred in build().
Aborting...

After modified items like this :

--- transition-check.pl.old 2013-06-24 15:35:36.728357161 +0200
+++ transition-check.pl 2013-06-24 15:35:06.405175102 +0200
@@ -58,12 +58,12 @@ be involved in a transition.

=over 4

-=item 0
+=item toto

Either B<--help> or B<--version> was used, or none of the packages examined
was involved in a transition.

-=item 1
+=item titi

At least one package examined is involved in a current transition.

I have a new error :

po4a --previous --no-backups devscripts-po4a.conf
'tempfile' can't be called as a method at /usr/share/perl5/vendor_perl/Locale/Po4a/Po.pm line 575.
make[1]: *** [translate] Error 255
make[1]: Leaving directory `/home/alain/AUR/devscripts/src/devscripts-2.10.69+squeeze4/po4a'
make: *** [translated_manpages] Error 2
==> ERROR: A failure occurred in build().
Aborting...

I don't solve this error.