Warning: file_exists(): open_basedir restriction in effect. File(/srv/http/vhosts/aur.archlinux.org/public/web/locale//en/LC_MESSAGES/aurweb.mo) is not within the allowed path(s): (/srv/http/vhosts/aur-dev.archlinux.org/:/etc/aurweb/) in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/streams.php on line 90
AUR (en) - cython2-kivy

Notice: Undefined variable: name in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/pkgfuncs.inc.php on line 248

Package Details: cython2-kivy 0.23-1

Git Clone URL: https://aur-dev.archlinux.org/cython2-kivy.git (read-only)
Package Base: cython2-kivy
Description: C-Extensions for Python; Kivy-compatible version
Upstream URL: http://www.cython.org
Licenses: Apache
Conflicts: cython2
Provides: cython2=0.23
Submitter: mixedCase
Maintainer: mixedCase
Last Packager: mixedCase
Votes: 12
Popularity: 0.002618
First Submitted: 2015-03-02 04:50
Last Updated: 2016-07-01 18:08

Required by (133)

Sources (1)

Latest Comments

mixedCase commented on 2016-07-01 18:10

@odiogosilva thanks for reporting. URL updated.

PS: Middle finger right back at you PyPI. Love, package maintainers.

odiogosilva commented on 2016-07-01 18:02

The source url is outdated and the packaging fails. I got it working using the new URL in https://pypi.python.org/pypi/Cython/0.23

mixedCase commented on 2015-11-11 10:46

Vendoring is just relying on a particular kivy-git commit for all your builds and sticking on that one until you decide to update. Easily done by forking the github repo to your account and changing the clone address in python2-kivy-git's PKGBUILD.

The naming change proposal has merit. I'll look into it sometime.

meZee commented on 2015-11-11 06:30

What is vendoring, and what is wrong with kivy? I think this package should be in cython2-kivy-git to stay consistent, it wouldn't make much sense to use cython2-kivy-git for python2-kivy, and as is the package is broken and not building because of the version incompatibility.

Thanks,
meZee

mixedCase commented on 2015-11-09 15:48

meZee, those docs are outdated. If you would've tried to install the package, you'd see it would work.

EDIT: I just saw that you refer to Kivy 1.9.0. This package is for the git version of kivy. Really, you shouldn't be using Kivy stable even for production. If you wanna be safe, practice vendoring.

meZee commented on 2015-11-08 09:10

v0.23 of cython is incompatible with kivy v1.9.0, and v0.21.2 of cython is recommended.[1]

[1]- http://kivy.org/docs/installation/installation-linux.html#cython

rdoursenaud commented on 2015-05-14 08:08

v0.21.2 is now recommended for kivy.
Thanks!