Warning: file_exists(): open_basedir restriction in effect. File(/srv/http/vhosts/aur.archlinux.org/public/web/locale//en/LC_MESSAGES/aurweb.mo) is not within the allowed path(s): (/srv/http/vhosts/aur-dev.archlinux.org/:/etc/aurweb/) in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/streams.php on line 90
AUR (en) - couchbase-server-community

Notice: Undefined variable: name in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/pkgfuncs.inc.php on line 248

Package Details: couchbase-server-community 4.5.0-1

Git Clone URL: https://aur-dev.archlinux.org/couchbase-server-community.git (read-only)
Package Base: couchbase-server-community
Description: A document database featuring a powerful query language and unrivaled performance at scale.
Upstream URL: http://www.couchbase.com/
Keywords: database nosql
Submitter: BombStrike
Maintainer: BombStrike
Last Packager: BombStrike
Votes: 3
Popularity: 0.004909
First Submitted: 2015-11-02 14:28
Last Updated: 2017-01-22 11:39

Latest Comments

kingtong commented on 2017-01-20 16:36

Added some changes to upgrade to 4.5.0 & fix libtinfo5 dep.
But I'm behind my company firewall, ssh is not open, ...

So here is the patch if it makes sense.


From f154d7c6a0e0105342eb36434983a21d8faf2d7f Mon Sep 17 00:00:00 2001
From: Nicolas Olivier <nicolas.olivier@protonmail.com>
Date: Fri, 20 Jan 2017 11:24:30 -0500
Subject: [PATCH] Bump to version 4.5.0 & fix libtinfo5 dep

---
PKGBUILD | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/PKGBUILD b/PKGBUILD
index d772d75..3c3eb77 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Christophe Robin <crobin at nekoo a-dot com>

pkgname=couchbase-server-community
-pkgver=4.0.0
+pkgver=4.5.0
pkgrel=4
pkgdesc="A document database featuring a powerful query language and unrivaled performance at scale."
arch=('x86_64')
@@ -11,7 +11,7 @@ source=(
"couchbase-server.service"
)
install=couchbase-server.install
-depends=(glibc gcc-libs sqlite openssl libtinfo5 zlib)
+depends=(glibc gcc-libs sqlite openssl ncurses5-compat-libs zlib)

package() {
msg2 "Extracting the data.tar.gz"
@@ -22,5 +22,5 @@ package() {
install -D couchbase-server.service "${pkgdir}/usr/lib/systemd/system/couchbase-server.service"
}

-md5sums=('950bf7eeebc139c1602d322d675e6d98'
+md5sums=('441cd6928b599d5d8e86df25818c10a9'
'd6d13dde7d40fb31e786623f3f16c3c2')
--
2.11.0

hav3lock commented on 2016-05-24 22:31

libtinfo-5 will be now called libtinfo5, please update your package accordingly.

daku commented on 2016-04-24 03:49

After an upgrade pacman -Syu can't restart couchbase:

● couchbase-server.service - Couchbase Server
Loaded: loaded (/usr/lib/systemd/system/couchbase-server.service; disabled; vendor preset: disabled)
Active: failed (Result: exit-code) since Sat 2016-04-23 20:43:16 PDT; 3s ago
Docs: http://docs.couchbase.com
Process: 31111 ExecStart=/opt/couchbase/bin/couchbase-server -noinput -detached > /opt/couchbase/var/lib/couchbase/logs/start.log 2>&1

Apr 23 20:43:16 dakudell systemd[1]: Starting Couchbase Server...
Apr 23 20:43:16 dakudell couchbase[31111]: /opt/couchbase/bin/couchbase-server: illegal option -- n
Apr 23 20:43:16 dakudell couchbase[31111]: /opt/couchbase/lib/erlang/erts-5.10.4.0.0.1/bin/beam.smp: error while loading shared libraries libtinfo.so.5: cannot open shared object file: No such file or directory
Apr 23 20:43:16 dakudell systemd[1]: couchbase-server.service: Control process exited, code=exited status=1
Apr 23 20:43:16 dakudell systemd[1]: Failed to start Couchbase Server.
Apr 23 20:43:16 dakudell systemd[1]: couchbase-server.service: Unit entered failed state.
Apr 23 20:43:16 dakudell systemd[1]: couchbase-server.service: Failed with result 'exit-code'.


See latest comment for package libtinfo:

https://aur.archlinux.org/packages/libtinfo/

@Everyone, I'm going to remove the .5 link from libtinfo, remove the conflict between this and libtinfo-5, so that they can be installed alongside each other.

Please notify me asap if this change has any negative repercussions.

WORKAROUND:
$ gpg --keyserver pgp.mit.edu --recv-keys F7E48EDB
$ yaourt -S libtinfo-5

BombStrike commented on 2015-12-16 01:28

Indeed, good catch on that one, fixed it in 4.0.0-2

chetjan commented on 2015-12-14 16:36

Installation worked great, but the url is incorrect. Seems like you recently uploaded a package for url="http://www.manager.io" as well, so likely a typo from copying PKGBUILD.