Warning: file_exists(): open_basedir restriction in effect. File(/srv/http/vhosts/aur.archlinux.org/public/web/locale//en/LC_MESSAGES/aurweb.mo) is not within the allowed path(s): (/srv/http/vhosts/aur-dev.archlinux.org/:/etc/aurweb/) in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/streams.php on line 90
AUR (en) - coreutils-selinux

Notice: Undefined variable: name in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/pkgfuncs.inc.php on line 248

Package Details: coreutils-selinux 8.26-1

Git Clone URL: https://aur-dev.archlinux.org/coreutils-selinux.git (read-only)
Package Base: coreutils-selinux
Description: The basic file, shell and text manipulation utilities of the GNU operating system with SELinux support
Upstream URL: https://www.gnu.org/software/coreutils/
Licenses: GPL3
Groups: selinux
Conflicts: coreutils, selinux-coreutils
Provides: coreutils=8.26-1, selinux-coreutils=8.26-1
Submitter: Siosm
Maintainer: IooNag
Last Packager: IooNag
Votes: 19
Popularity: 0.967733
First Submitted: 2013-11-03 20:05
Last Updated: 2016-12-19 11:41

Required by (431)

Sources (3)

Latest Comments

« First ‹ Previous 1 2 3 Next › Last »

xangelux commented on 2013-02-10 17:44

By the way, just a warning was raised, the file etc/pam.d/su doesn't exist from the backup input

xangelux commented on 2013-02-10 17:34

Thanks Nicky726, I'll install one by one and if I encounter any issues I'll tell you about it, I'll try to install every selinux package and set it to permissive to test. By the way, are you still using sysvinit or switched to systemd?

Nicky726 commented on 2013-02-10 17:25

All packages from selinux-system-utilities group + the kernel should now be up-to-date with [core]. I gave them some testing in my virtualized machine, but I'm currently stuck with loading SELinux policy, so I tested them in non-SELinux system. I may give it one more try today, or I'll look into it next weekend.

Nicky726 commented on 2013-02-10 17:14

I'll update the selinux-system-utilities packages.

xangelux commented on 2013-02-10 17:07

Should I just change the version to 8.20? or just change the PKGBUILD file for the kernel so it doesn't need this package but the default coreutils?

If I change the version number only it tryes to patch with the old patches, are those related to selinux or I should only delete them?

Nicky726 commented on 2013-02-10 16:18

With version 8.20 it builds and installs fine. It also seems to work on on non-SELinux testmachine.

xangelux commented on 2013-02-10 06:48

Hi, I've come this far, now selinux-coreutils fails to install but not to build. It complains about conflicting files /bin/su, /etc/pam.d/su and /usr/share/man/man1/su.1.gz

I have tested the install of selinux-pam with siosm's and it compiles and installs without problems but when I come to selinux-coreutils it fails to install, I will see if I can update the pkgbuild file to see if it's a version problem.

Anonymous comment on 2012-06-19 09:07

You're right. The problem isn't with the selinux support. Even the core package from ABS fails the test. Sorry for the trouble.

Nicky726 commented on 2012-06-18 12:45

Hi, I just build if without troubles. Does the test also fail if you build coreutils from abs?

Anonymous comment on 2012-06-17 15:23

One of the tests also fails for me: stty-pairs. The log for the test is full of lines like
stty: standard input: unable to perform all requested operations
and I always seem to get that error after stty commands including "parodd", however not all commands with "parodd" result in an error.

Any idea why this happens? Or can I just safely ignore it?

Thanks,
gsx1022