Warning: file_exists(): open_basedir restriction in effect. File(/srv/http/vhosts/aur.archlinux.org/public/web/locale//en/LC_MESSAGES/aurweb.mo) is not within the allowed path(s): (/srv/http/vhosts/aur-dev.archlinux.org/:/etc/aurweb/) in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/streams.php on line 90
AUR (en) - conky-lua

Notice: Undefined variable: name in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/pkgfuncs.inc.php on line 248

Package Details: conky-lua 1.10.1-7

Git Clone URL: https://aur-dev.archlinux.org/conky-lua.git (read-only)
Package Base: conky-lua
Description: Lightweight system monitor for X, with Lua support enabled
Upstream URL: http://github.com/brndnmtthws/conky
Keywords: conky conky-lua
Licenses: GPL3, BSD
Conflicts: conky
Provides: conky=1.10.1
Replaces: torsmo
Submitter: alexiobash
Maintainer: TidestManager1
Last Packager: TidestManager1
Votes: 32
Popularity: 0.771980
First Submitted: 2015-08-12 18:00
Last Updated: 2016-04-02 03:43

Latest Comments

« First ‹ Previous 1 2 3 4 5 Next › Last »

moonarch commented on 2016-03-26 21:41

I am no longer on Arch and so can not generate the .SRCINFO for TidestManager1 update.

@TidestManager1 I have added you as maintainer. Can you push the new version?

bastelfreak commented on 2016-03-26 21:19

Hi, could someone please upload a new version of the PKGBUILD? It is currently broken:

TidestManager1 commented on 2016-03-15 09:15

Updated PKGBUILD at http://pastebin.com/URsddkuz

Shamelessly bodged from this, gentoo's conky build script, and conky-lua-nv.

tiberiomoliveira commented on 2016-02-20 23:21

@scofi16 Just put it at the end of the PKGBUILD file.

@benjarobin It worked like a charm. Good job.

scofi16 commented on 2016-02-18 15:16

@benjarobin where to add this function?

benjarobin commented on 2016-02-13 14:31

Just add the following function to fix it:

prepare() {
cd "${srcdir}/${_pkgname}-${pkgver}"
sed -i "s|tolua++ |toluapp |g" configure*

krs4keshara commented on 2016-02-02 07:05

as a workaround, install 'conky-lua-nv" from AUR.

ketzalv commented on 2016-01-25 03:49

Hello guys! i have a little solution with "configure: error: tolua++, tolua++5.1, or tolua++-5.1 is required for Lua extras."

you need downgrade tolua++ 1.093-2

here the old versions!

eduncan911 commented on 2016-01-19 01:53

The problem with the 'tolua++' dependency is that the source configure is looking for a binary '/usr/bin/tolua++'.

It would appear that binary has been renamed to 'toluapp' in the latest version of 1.93-2. The maintained and updated package by arch, as well as in the manual download of 1.93-2, seems to have renamed it (not Arch's fault, the fault of the author of the code that renamed everything).

In addition, the library was changed (*.so instead of *.a).

Personally, I don't like to get away from Arch's repos and packages - would rather have it fixed in this package. So, there are two "real" solutions.

The original package of tolua++ should have explained the breaking change of the rename. I would suggestion creating a symlink of the old binary to the new one.

1) Perhaps the easiest solution is just to modify this package to 'sed' the source configure file and replace all instances looking for the binaries with the newer/correct one.

2) The real solution is to have conky update their source to configure with either binary.


TiglathAshur commented on 2015-12-13 00:08

Thanks Stormeye! Works well now