Notice: Undefined variable: name in /srv/http/vhosts/ on line 248

Package Details: conky-lua 1.10.1-7

Git Clone URL: (read-only)
Package Base: conky-lua
Description: Lightweight system monitor for X, with Lua support enabled
Upstream URL:
Keywords: conky conky-lua
Licenses: GPL3, BSD
Conflicts: conky
Provides: conky=1.10.1
Replaces: torsmo
Submitter: alexiobash
Maintainer: TidestManager1
Last Packager: TidestManager1
Votes: 32
Popularity: 0.771980
First Submitted: 2015-08-12 18:00
Last Updated: 2016-04-02 03:43

Latest Comments

1 2 3 4 5 Next › Last »

bastelfreak commented on 2016-09-25 13:22

I'm unable to build the PKGBUILD in a fresh arch nspawn container:

-- Checking for one of the modules 'lua=5.1;lua5.1;lua-5.1'
CMake Error at /usr/share/cmake-3.6/Modules/FindPkgConfig.cmake:646 (message):
None of the required 'lua=5.1;lua5.1;lua-5.1' found
Call Stack (most recent call first):
cmake/ConkyPlatformChecks.cmake:252 (pkg_search_module)
CMakeLists.txt:37 (include)

-- Checking for modules 'cairo;cairo-xlib'
-- Found cairo, version 1.14.6
-- Found cairo-xlib, version 1.14.6
-- Checking for module 'imlib2'
-- Found imlib2, version 1.4.9
-- Checking for module 'librsvg-2.0'
-- No package 'librsvg-2.0' found
CMake Error at /usr/share/cmake-3.6/Modules/FindPkgConfig.cmake:424 (message):
A required package was not found
Call Stack (most recent call first):
/usr/share/cmake-3.6/Modules/FindPkgConfig.cmake:597 (_pkg_check_modules_internal)
cmake/ConkyPlatformChecks.cmake:274 (pkg_check_modules)
CMakeLists.txt:37 (include)

-- Configuring incomplete, errors occurred!
See also "/build/conky-lua/src/conky-1.10.1/CMakeFiles/CMakeOutput.log".
See also "/build/conky-lua/src/conky-1.10.1/CMakeFiles/CMakeError.log".
==> ERROR: A failure occurred in build().

7etc commented on 2016-08-13 22:03

I've installed first git, then pacman -U lua51-5.1.5-4-x86_64.pkg.tar.xz, and installation works fine. After installation there's no problem tu update lua

drxspace commented on 2016-08-01 07:23

What about this -or- this ?

ata commented on 2016-07-25 21:52

hi alls m fix

and saıd makepkg -sri after

opened here
sudo gedit /usr/share/cmake-3.6/Modules/FindPkgConfig.cmake

and edit

# check whether version is given
if (_pkg_check_modules_pkg MATCHES "(.*[^><])(>=|=|<=)(.*)")
set(_pkg_check_modules_pkg_name "${CMAKE_MATCH_1}")
set(_pkg_check_modules_pkg_op "${CMAKE_MATCH_2}")
set(_pkg_check_modules_pkg_ver "${CMAKE_MATCH_3}")
set(_pkg_check_modules_pkg_name "${_pkg_check_modules_pkg}")

delate itis
set(_pkg_check_modules_pkg_name "${_pkg_check_modules_pkg}")
and try makepkg -sri

enjoy all

look at

or u want tar.xz here

techMod commented on 2016-07-20 10:57

Doesn´t build, cmke.patch didn´t pass check for sha1sum

m3thodic commented on 2016-07-04 21:40

The following PKGBUILD fixes lua5.1 compilation issues as well as speeding up compilation time:



dbenque commented on 2016-06-23 21:58

@firekage, I had the same problem.
If lua51 is installed on your system next to lua5.3 then what you can do:

clone the github repo:

in the file cmake/ConkyPlatformChecks.cmake, modify the check and library settings for LUA in the following way (close to line 259):
# If we need tolua++, we must compile against Lua 5.1
pkg_search_module(LUAAA REQUIRED lua51)
message(FATAL_ERROR "Unable to find lua51: version '${LUAAA_VERSION}'")
# Otherwise, use the most recent Lua version
pkg_search_module(LUA REQUIRED lua>=5.3 lua5.3 lua-5.3 lua53 lua5.2 lua-5.2 lua52 lua5.1 lua-5.1 lua51 lua>=5.1)
set(conky_libs ${conky_libs} ${LUAAA_LIBRARIES})
set(conky_includes ${conky_includes} ${LUAAA_INCLUDE_DIRS})

Then follow the make and install procedure under the wiki of the project.
At config time set option ON for BUILD_LUA_CAIRO (or IMLIB2 or RSVG)

firekage commented on 2016-06-19 15:34

I cant install it:

checking for one of the modules 'lua=5.1;lua5.1;lua-5.1'
CMake Error at /usr/share/cmake-3.5/Modules/FindPkgConfig.cmake:574 (message):
None of the required 'lua=5.1;lua5.1;lua-5.1' found
Call Stack (most recent call first):

I have lua installed in version 5.3, but it needs 5.1. Could somebody help?

argamanza commented on 2016-04-16 20:10

When i'm trying to install the package i get:

Scanning dependencies of target docs
[ 21%] Proccessing man page for docs
warning: failed to load external entity ""
cannot parse
doc/CMakeFiles/docs.dir/build.make:60: recipe for target 'doc/docs.html' failed
make[2]: *** [doc/docs.html] Error 4
make[2]: *** Deleting file 'doc/docs.html'
CMakeFiles/Makefile2:357: recipe for target 'doc/CMakeFiles/docs.dir/all' failed
make[1]: *** [doc/CMakeFiles/docs.dir/all] Error 2
Makefile:149: recipe for target 'all' failed
make: *** [all] Error 2
==> ERROR: A failure occurred in build().
==> ERROR: Makepkg was unable to build conky-lua.

What's wrong and what can i do to repair it?

sdothum commented on 2016-04-01 19:21

Could you please add to the PKGBUILD


to the build() options? Would be a convenience for those of us monitoring wireless interfaces.

Thanks regardless, for the pkg.