Warning: file_exists(): open_basedir restriction in effect. File(/srv/http/vhosts/aur.archlinux.org/public/web/locale//en/LC_MESSAGES/aurweb.mo) is not within the allowed path(s): (/srv/http/vhosts/aur-dev.archlinux.org/:/etc/aurweb/) in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/streams.php on line 90
AUR (en) - conky-lua-nv

Notice: Undefined variable: name in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/pkgfuncs.inc.php on line 248

Package Details: conky-lua-nv 1.10.6-1

Git Clone URL: https://aur-dev.archlinux.org/conky-lua-nv.git (read-only)
Package Base: conky-lua-nv
Description: An advanced system monitor for X based on torsmo with lua and nvidia enabled
Upstream URL: https://github.com/brndnmtthws/conky
Licenses: GPL3, BSD
Conflicts: conky
Provides: conky, conky-lua
Replaces: conky, torsmo
Submitter: Andrwe
Maintainer: Foucault
Last Packager: Foucault
Votes: 105
Popularity: 0.522332
First Submitted: 2010-04-12 04:55
Last Updated: 2016-12-29 10:46

Latest Comments

« First ‹ Previous 1 2 3 4 5 Next › Last »

mandog commented on 2015-04-02 13:49

Unfortunately this version has stopped drawing Lua on my conky only nvidia and other text are displayed

Foucault commented on 2014-10-14 15:25

I suppose he's correct, although this is not the ideal solution, since there are version conditionals available for such cases. Anyway, since there are no direct dependencies in ldd for nvidia then let's leave at that and not over-complicate things for the package maintainer. This package is minor anyway. That also makes me wonder why extra/conky is not built with nvidia support since conky does not require any nvidia-specific libraries on runtime.

Foucault commented on 2014-10-14 15:23

I suppose he's correct, although this is not the ideal solution, since there are version conditionals available for such cases. Anyway, since there are no direct dependencies in ldd for nvidia then let's leave at that and not over-complicate things.

Chimyx commented on 2014-10-14 12:35

Here's what the packager thinks about this :
http://www.reddit.com/r/archlinux/comments/2ic9na/arch_linux_news_nvidia340xx_and_nvidia/cl1gg3m

Foucault commented on 2014-10-12 08:25

Yes, I am aware of that. In my opinion this is a problem with the nvidia packages, as they should all provide nvidia (and conflict with each other), but I am not sure this is possible to happen. However, since libxnvctrl is statically linked and no nvidia-specific libraries are present on ldd then I suppose the easiest thing to do would be to move nvidia to opt-depends (along with the 304, 340 packages)

gric commented on 2014-10-12 08:03

nvidia package 343.22 dropped support for G8x, G9x, and GT2xx GPUs [1]: we need to fallback on nvidia-340xx package, which does not provide 'nvidia' package anymore. Since conky-lua-nv requires 'nvidia' package as a dependency, it is not possible to use it anymore with G8x, G9x, and GT2xx GPUs.
Maybe nvidia should be an opt dependency ?

[1] https://www.archlinux.org/news/nvidia-340xx-and-nvidia/

Foucault commented on 2014-04-29 16:24

For people having problem with recent libxnvctrl update (337.12) it seems the libxnvctrl package is missing the shared library and only includes the static (not sure if it's a bug or a feature). Just rebuild the package and the linker will link against the static lib instead.

Foucault commented on 2014-02-08 16:20

Please do not flag out of date packages that fail to build/work but are otherwise up to date with upstream. Comments will suffice :)

Since AUR does not host binaries I believe there is no reason to increase package version for so bumps. Just reinstall/rebuild!

Alda commented on 2014-02-08 15:44

Because of a wireless_tools update, we need to recompile conky. Pkg version bump ?

Foucault commented on 2013-10-18 17:11

Done!