Warning: file_exists(): open_basedir restriction in effect. File(/srv/http/vhosts/aur.archlinux.org/public/web/locale//en/LC_MESSAGES/aurweb.mo) is not within the allowed path(s): (/srv/http/vhosts/aur-dev.archlinux.org/:/etc/aurweb/) in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/streams.php on line 90
AUR (en) - codelite-bin

Notice: Undefined variable: name in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/pkgfuncs.inc.php on line 248

Package Details: codelite-bin 10.0.0-1

Git Clone URL: https://aur-dev.archlinux.org/codelite-bin.git (read-only)
Package Base: codelite-bin
Description: A cross platform C/C++/PHP and Node.js IDE written in C++
Upstream URL: http://www.codelite.org/
Keywords: C C++ IDE Node.js PHP wxGtk wxWidgets
Licenses: GPL
Provides: codelite
Replaces: codelite, codelite-svn
Submitter: agvares
Maintainer: Zeph
Last Packager: Zeph
Votes: 24
Popularity: 0.033247
First Submitted: 2010-09-05 15:22
Last Updated: 2017-01-03 20:56

Latest Comments

« First ‹ Previous 1 2 3 Next › Last »

underdoeg commented on 2015-08-04 08:49

Also depends on mspack

"codelite: error while loading shared libraries: libmspack.so.0: cannot open shared object file: No such file or directory"

Jim_D commented on 2015-08-04 08:49

A dependency is missing: libmspack

https://www.archlinux.org/packages/extra/x86_64/libmspack/
https://www.archlinux.org/packages/extra/i686/libmspack/

SoleSoul commented on 2013-12-22 19:55

libssh is also required. CodeLite doesn't run without it.

SoleSoul commented on 2013-07-13 21:01

I think webkitgtk2 should be added as a dependency. It won't run without it.

Zeph commented on 2013-03-22 21:50

I've update package to codelite 5.1
now the bin provide from fedora 18 and include wxcrafter 1.1
Clean wxgtk lib already include in arch
Install i686 not tested :(

jorge_barroso commented on 2013-03-22 13:16

Hello, I've tried to install this package on a i686 pc and it is an odisey :S so I'd like to sahre with you some changes yo could/should do on the PKGBUILD. It was a little bit long so I've writen it on a pastebin for you to check it:

http://pastebin.com/81CuTKRW

speps commented on 2012-05-31 23:34

I'll delete codelite-bin in a week if no one wants to adopt and update it.

speps commented on 2012-05-31 23:28

merging codelite-x86_64 into codelite-bin as it satisfy the same purpose.

nem commented on 2012-05-30 17:20

the codelite package http://aur.archlinux.org/packages.php?ID=18809 is the stable version and also compiles and runs on x86_64. any problem you have is not related to 64bit incompatibility. this package is redundant.

Zeph commented on 2012-01-25 23:48

This is the stable version.
Direct download bin from sourceforge for ubuntu 64.
Work nice with wxgtk from repo [extra].