Warning: file_exists(): open_basedir restriction in effect. File(/srv/http/vhosts/aur.archlinux.org/public/web/locale//en/LC_MESSAGES/aurweb.mo) is not within the allowed path(s): (/srv/http/vhosts/aur-dev.archlinux.org/:/etc/aurweb/) in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/streams.php on line 90
AUR (en) - ckb-git

Notice: Undefined variable: name in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/pkgfuncs.inc.php on line 248

Package Details: ckb-git v0.2.6.r1.geb1fe4e-1

Git Clone URL: https://aur-dev.archlinux.org/ckb-git.git (read-only)
Package Base: ckb-git
Description: Corsair Keyboard and Mouse Input Driver
Upstream URL: https://github.com/ccMSC/ckb
Keywords: ckb corsair driver
Licenses: GPL2
Conflicts: ckb-git-latest
Submitter: penetal
Maintainer: Light2Yellow
Last Packager: Light2Yellow
Votes: 19
Popularity: 2.689484
First Submitted: 2015-02-22 22:44
Last Updated: 2016-06-30 12:42

Required by (0)

Sources (1)

Pinned Comments

Light2Yellow commented on 2016-06-30 12:48

With a new version the firmware table for 2.05 was added. Also my other package (ckb-git-latest) becomes deprecated in it's current state (using the fw2kb branch) because it's not latest anymore and was supposed to fix older issues, so I've removed the warning from this package and will update the second one to use the testing branch, as upstream proposes. Stay tuned.
UPD. The second package now follows the testing branch so it is recommended that from now for fully stable work you'd better install this package.

Latest Comments

1 2 Next › Last »

The_Foxx commented on 2017-01-31 02:50

Can this be moved to ckb-next? Ckb seems to be broken for my mouse, while next works. I assume there are numerous other fixes in next as well.

Edit: Sorry. I just ready your comment, Light2Yellow. Looking forward to the change.

Light2Yellow commented on 2017-01-21 16:42

For those interested: there's a fork of ckb, called ckb-next: https://github.com/mattanger/ckb-next
I'll ship it as new packages (both stable and testing) as soon as the project cuts its first release.

gbc921 commented on 2016-10-27 00:44

I also had to install qt5ct to be able to change colors and avoid the critical error:

"GLib-GObject-CRITICAL **: g_type_add_interface_static: assertion 'G_TYPE_IS_INSTANTIATABLE (instance_type)' failed"

This may be temporary as this thread [1] states that this is a QT issue regarding GTK libs not being included anymore, but will be again in November.

Thanks for the great work though! Very nice!

[1]: https://bbs.archlinux.org/viewtopic.php?pid=1658017#p1658017

Light2Yellow commented on 2016-06-30 12:48

With a new version the firmware table for 2.05 was added. Also my other package (ckb-git-latest) becomes deprecated in it's current state (using the fw2kb branch) because it's not latest anymore and was supposed to fix older issues, so I've removed the warning from this package and will update the second one to use the testing branch, as upstream proposes. Stay tuned.
UPD. The second package now follows the testing branch so it is recommended that from now for fully stable work you'd better install this package.

Light2Yellow commented on 2016-06-17 09:33

Updated to 0.2.6. It is possible that now the version from fw2kb branch is not needed (on which ckb-git-latest is based) but I'm not sure because I didn't test it. But you still can.

Light2Yellow commented on 2016-06-02 19:29

Updated the package.
Also added a notice that with firmware 2.04 and later you should use ckb-git-latest.

Light2Yellow commented on 2016-05-22 13:01

https://aur.archlinux.org/packages/ckb-git-latest/
Here is an up-to-date package which builds the fw2kb branch. It should fix latest problems with incompatible firmware.

liganic commented on 2015-08-12 17:23

Thanks for the notice, fixed the package.

gondsman commented on 2015-08-12 16:55

There seems to be an error with this package about where it stores animation data. For more information:
https://github.com/ccMSC/ckb/issues/102#issuecomment-130235978

liganic commented on 2015-08-12 13:15

@qKUqm3wtY4: What gave you the impression that it isn't?
There is no aur4/aur3 distinction anymore, aur3 is gone and what's left has been migrated to aur4.