Notice: Undefined variable: name in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/pkgfuncs.inc.php on line 248

Package Details: catalyst-hook 15.9-14

Git Clone URL: https://aur-dev.archlinux.org/catalyst-hook.git (read-only)
Package Base: catalyst-hook
Description: AMD/ATI drivers. Auto re-compile fglrx module while shutdown/reboot.
Upstream URL: http://www.amd.com
Licenses: custom
Conflicts: catalyst, catalyst-daemon, catalyst-dkms, catalyst-generator, catalyst-test
Provides: catalyst=15.9
Submitter: Vi0L0
Maintainer: Vi0L0
Last Packager: Vi0L0
Votes: 98
Popularity: 0.087055
First Submitted: 2010-09-15 17:45
Last Updated: 2016-12-11 19:47

Required by (3)

Sources (18)

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 ... Next › Last »

beroal commented on 2015-08-21 08:36

What about "linux 4.1"? Should I downgrade the kernel or wait when Vi0L0 will fix this package?

kox commented on 2015-07-17 07:07

Hello, I use your drivers from catalyst-hd234k and it seems catalyst hook doesn't support linux>=4.1
I can't upgrade my system:
error: failed to prepare transaction (could not satisfy dependencies)
:: catalyst-hook: requires linux<4.1

Vi0L0 commented on 2015-06-04 13:20

updated to 15.5-1 - AKA "nothing interesting":
- it doesn't support xserver 1.17
- looks older than ubuntu vivid driver which we are using ie in catalyst-test@AUR
- i've added initial support for 4.1 kernel (using kolasa's patch, tested on 4.1rc5)
- rel notes: http://support.amd.com/en-us/kb-articles/Pages/AMDCatalyst15-5LINReleaseNotes.aspx

Vi0L0 commented on 2015-05-04 19:23

14.12-3:
- 4.0 kernel support (thanks to kolasa for patch)

Vi0L0 commented on 2015-03-08 13:31

14.12-2:
- using kolasa's patch to cover 3.19 kernel support

JoZ3 commented on 2014-10-05 23:51

Thanks for your help, I use Manjaro, the problem is that when updating the catlyst-ustils from AUR deleted me Manjaro basic components, then I'll wait for the Manjaro update to continue using these because I had gotten used to using the kernel ck :(

Vi0L0 commented on 2014-10-05 21:00

Log is pretty clear:

[ 10.859] (WW) fglrx(0): Kernel Module version does *not* match driver.
[ 10.859] (EE) fglrx(0): incompatible kernel module detected - HW accelerated OpenGL will not work

Looks like you didn't update catalyst-utils package (btw ever think about using catalyst-total package? or catalyst-test if wants some beta testing?), because log claims that ie:

[ 10.407] (II) Loading /usr/lib/xorg/modules/drivers/fglrx_drv.so
[ 10.449] (II) Module fglrx: vendor="FireGL - AMD Technologies Inc."
[ 10.449] compiled for 1.4.99.906, module version = 14.10.2

while should be:
[ 2.591] (II) Loading /usr/lib/xorg/modules/drivers/fglrx_drv.so
[ 2.619] (II) Module fglrx: vendor="FireGL - AMD Technologies Inc."
[ 2.619] compiled for 1.4.99.906, module version = 14.30.4

JoZ3 commented on 2014-10-05 19:46

Hi, the kernel modules was build, I ran

systemctl enable catalyst-hook
systemctl start catalyst-hook

and late:

catalyst_build_module all

I try all over again to have the Xorg.0.log file:

http://pastebin.com/3GRqRu50

Vi0L0 commented on 2014-10-05 09:46

Maybe kernel module wasn't build? Have you enabled automatic recompilation with:
systemctl enable catalyst-hook
systemctl start catalyst-hook
?
You can also build modules manually after every kernel update with:
catalyst_build_module all
I recommand to run it this time and if there's an error paste the error log here.

If there's no compilation error and X didn't start then maybe you will be able to get /var/log/Xorg.0.log ?
Normally there's no problem with logging to tty, even if X failed (maybe you got some problem in systemd?). Check if you will be able to login after disabling your DM/X from autostart.
You should now be able to login an start DM/X manually - if it will fail and you won't be able to get back to tty, reboot the machine (ie. in safe way via ssh), Xorg.0.log should be there with an error.

JoZ3 commented on 2014-10-05 06:46

Hello, I've installed the kernel 3.16.2 and kernel ck 3.16.3 ck without any problem, but after reboot, after the grub, the console appears blinking constantly and it is impossible to enter a username. The xserver 1.15.2

The above version working flawless