Notice: Undefined variable: name in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/pkgfuncs.inc.php on line 248

Package Details: catalyst-generator 15.9-14

Git Clone URL: https://aur-dev.archlinux.org/catalyst-generator.git (read-only)
Package Base: catalyst-generator
Description: AMD/ATI drivers. Generator of catalyst-{kernver} packages with fglrx module inside.
Upstream URL: http://www.amd.com
Licenses: custom
Conflicts: catalyst, catalyst-daemon, catalyst-dkms, catalyst-hook, catalyst-test
Provides: catalyst=15.9
Submitter: Vi0L0
Maintainer: Vi0L0
Last Packager: Vi0L0
Votes: 25
Popularity: 0.000000
First Submitted: 2010-09-22 22:52
Last Updated: 2016-12-11 19:46

Dependencies (10)

Required by (3)

Sources (20)

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 9 10 ... Next › Last »

Roken commented on 2012-12-28 20:26

PKGBUILD is at http://pastebin.com/vQXYCvVx

And config is at http://pastebin.com/N20f4ukp

The PKGBUILD is the AUR PKGBUILD for linux-git, slightly modifed to get the config of the currently running kernel.

Vi0L0 commented on 2012-12-28 19:48

sure,
i would also like to look at pkgbuild/install files of your kernel

Roken commented on 2012-12-26 19:39

Yes - it's the same error. I definitely have the uapi directory in kernel headers, and it does work for the core kernel, which is why I think I may be missing a kernel config option in more recent builds. I'm building with the same config, but given the changes to the kernel build, I'm not entirely sure what I may be missing.

Would it help if I posted my kernel config - maybe you can see what I'm missing?

Vi0L0 commented on 2012-12-25 18:40

is it returning same error you mentioned before?
this would be very strange.
btw are you including uapi directory into kernel' headers?
it's needed since 3.7
also: is generator working for core kernel?

ps. i dont have access to pc atm

Roken commented on 2012-12-25 12:42

No - I still can't build it with anything later than kernel 3.7-rc3. I'm obviously missing something but I have no idea what :(

Vi0L0 commented on 2012-12-22 21:41

@Roken, oh and as you said - there were no changes in kernel' drivers (like radeon) but there were changes in kernel's acpi section.
I've used my config from 3.7 kernel to build 3.8 one, no changes.

Vi0L0 commented on 2012-12-22 21:37

updated to 12.11-2:
- brings patch for 3.8 kernel

i really had not much time to work on it - less than 1 hour... it's compiling and looks like working fine, but i'm unable to perform more tests over this patch because i have to go to my family, will be back after a week.
Merry Christmas! ;)

Roken commented on 2012-12-22 16:59

I should add I'm using the main catalyst now (not hd234k) - I upgraded my gfx card :)

Roken commented on 2012-12-21 19:26

Trying to build with the latest git-kernel fails:

/tmp/catalyst.EwaasD/src/kcl_acpi.c:779:58: error: ‘struct dev_archdata’ has no member named ‘acpi_handle’

Now, acpi kernel options appear to have changed, and whilst I'm building everything that seems to be necessary, it's very possible I'm missing a kernel option (in which case please help). I can't see any significant changes to the graphics driver section.

Vi0L0 commented on 2012-10-16 18:38

12.9-2:
- added patch to support 3.7rc1 kernel, it's my own so i don't trust it ;P pls test (yup, seems to work fine here)