Notice: Undefined variable: name in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/pkgfuncs.inc.php on line 248

Package Details: catalyst-generator 15.9-14

Git Clone URL: https://aur-dev.archlinux.org/catalyst-generator.git (read-only)
Package Base: catalyst-generator
Description: AMD/ATI drivers. Generator of catalyst-{kernver} packages with fglrx module inside.
Upstream URL: http://www.amd.com
Licenses: custom
Conflicts: catalyst, catalyst-daemon, catalyst-dkms, catalyst-hook, catalyst-test
Provides: catalyst=15.9
Submitter: Vi0L0
Maintainer: Vi0L0
Last Packager: Vi0L0
Votes: 25
Popularity: 0.000000
First Submitted: 2010-09-22 22:52
Last Updated: 2016-12-11 19:46

Dependencies (10)

Required by (3)

Sources (20)

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 9 ... Next › Last »

Vi0L0 commented on 2013-03-25 19:08

package has been once again updated, but silently, no pkgrel bump
because AMD has changed files that don't belong to this package, only catalyst-utils/total*

Vi0L0 commented on 2013-03-21 18:51

package has been updated, but silently, no pkgrel
because AMD has changed files that don't belong to this package, only catalyst-utils/total*

Vi0L0 commented on 2013-03-16 15:24

silent update, no pkgrel bump:
- i've cleaned up PKGBUILD and catalyst_build_module, from now on it supports only kernels build with proper extramodules support, tested on -ARCH, -ck, -lts and -mainline

Vi0L0 commented on 2013-01-18 14:50

updated to 13.1-1:
- changelog is here: http://support.amd.com/us/kbarticles/Pages/AMDCatalyst131ProprietaryLinuxGraphicsDriverReleaseNotes.aspx

Roken commented on 2012-12-29 21:33

That was it. despite manually updating to be sure (packer -S catalyst-generator) it didn't update.

I manually downloaded the tarball and extracted to /usr/share/ati/build_mod then ran catalyst-build-module. This re-downloaded and buitl the driver but errored out at "/tmp/catalyst.randomechars/catalyst-3.8-git....... not found. CD's to the /tmp folder and pacman -U catalyst-generator.tar.gz, then re-issued catalyst-build-module and it's successfully built and installed.

I have no idea why catalyst-generator didn't update. though :/

Thanks for pointing me in the right direction.

Roken commented on 2012-12-29 21:33

That was it. despite manually updating to be sure (packer -S catalyst-generator) it didn't update.

I manually downloaded the tarball and extracted to /usr/share/ati/build_mod then ran catalyst-build-module. This re-downloaded and buitl the driver but errored out at "/tmp/catalyst.randomechars/catalyst-3.8-git....... not found. CD's to the /tmp folder and pacman -U catalyst-generator.tar.gz, then re-issued catalyst-build-module and it's successfully built and installed.

I have no idea why catalyst-generator didn't update. though :/

Thanks for pointing me in the right direction.

Roken commented on 2012-12-29 20:43

That was it. despite manually updating to be sure (packer -S catalyst-generator) it didn't update.

I manually downloaded the tarball and extracted to /usr/share/ati/build_mod then ran catalyst-build-module. This re-downloaded and buitl the driver but errored out at "/tmp/catalyst.randomechars/catalyst-3.8-git....... not found. CD's to the /tmp folder and pacman -U catalyst-generator.tar.gz, then re-issued catalyst-build-module and it's successfully built and installed.

I have no idea why catalyst-generator didn't update. though :/

Thanks for pointing me in the right direction.

Vi0L0 commented on 2012-12-29 18:46

also are you sure that generator was updated successfully?
ie is this file present: /usr/share/ati/build_mod/arch-fglrx-3.8.patch

Maybe you have changed something after 3.7rc3, like the way that /tmp is mounted?

Vi0L0 commented on 2012-12-29 18:39

Strange...
I've build this kernel using only your files (i only removed lines with steve :> and used directly your config).
i didn't try to run this kernel because i've got other hardware, but i was able to build fglrx module for your kernel, everything went smooth:

# catalyst_build_module 3.8.0-rc1+
Building fglrx module for 3.8.0-rc1+ kernel ...
Ok.


the module is right where it should be:
# ls -hl /lib/modules/extramodules-3.8-git/
-rw-r--r-- 1 root root 1,8M 12-29 19:13 fglrx.ko.gz
-rw-r--r-- 1 root root 11 12-29 19:10 version
# cat /lib/modules/extramodules-3.8-git/version
3.8.0-rc1+

umm... so i guess it's not your config, the fact that module was build is telling that also headers are fine.
Have you tried building module when other kernel, like arch' [core] kernel, was booted?

Roken commented on 2012-12-28 20:27

Oh, and the install file is:

pkgname=linux-git
kernver=3.8.0-rc1+

post_install () {
echo ">"
echo "> Updating module dependencies. Please wait ..."
depmod $kernver

echo ">"
echo "> Generating initramfs, using mkinitcpio. Please wait..."
echo ">"
mkinitcpio -p $pkgname
}

post_upgrade() {
post_install
}

post_remove() {
rm -f -- "boot/initramfs-$pkgname.img"
}