Package Details: camotics-git 1.0.6.r127.g776b29b-2

Git Clone URL: https://aur-dev.archlinux.org/camotics-git.git (read-only)
Package Base: camotics-git
Description: 3-axis NC machining simulation software
Upstream URL: http://camotics.org/
Keywords: CAM simulation
Licenses: GPL2
Provides: camotics
Replaces: openscam
Submitter: Crispy24
Maintainer: Crispy24
Last Packager: Crispy24
Votes: 1
Popularity: 0.000132
First Submitted: 2015-11-19 03:49
Last Updated: 2017-01-30 23:49

Latest Comments

Crispy24 commented on 2017-01-30 23:55

Package update:
I've changed the scons commands to force compilation against qt4.

greyltc commented on 2017-01-28 12:37

Hi Crispy24, could you please apply the fix that jb1 mentioned below? Without it this build is broken on systems with qt5 installed.

jb1 commented on 2017-01-20 11:36

I had both qt4 and qt5 installed and it tried to compile (unsuccessfully) against qt5.

Appending "qt_version=4" to the end of each of the 3 scons commands forced it to compile against qt4.

Crispy24 commented on 2017-01-07 18:49

Package update:
I've changed the package deps, and provided a desktop entry.
The package no longer depends on 'qt5-base', and now depends on 'qt4'.

Crispy24 commented on 2016-12-22 13:49

It's building and running just fine for me. I'll check the dependencies to make sure they're current.

greyltc commented on 2016-12-21 13:03

This isn't building for me. First error:
/usr/include/qt/QtCore/qcompilerdetection.h:562:6: error: #error Qt requires a C++11 compiler and yours does not seem to be that
Any ideas?

seoushi commented on 2016-05-14 18:38

This no longer builds due to v8-3.14 requiring google code which has been shutdown. The packages v8-3.15 is effected as well and the v8 package (which is 5.x) causes a build error when checking for v8. Is it possible to fix this package to work with the v8 package?

lllars commented on 2015-12-01 19:39

This compiles and runs okay for a me, although it does seem a bit buggier than the last time I compiled openscam (july 28 2005).