Warning: file_exists(): open_basedir restriction in effect. File(/srv/http/vhosts/aur.archlinux.org/public/web/locale//en/LC_MESSAGES/aurweb.mo) is not within the allowed path(s): (/srv/http/vhosts/aur-dev.archlinux.org/:/etc/aurweb/) in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/streams.php on line 90
AUR (en) - brave-git

Notice: Undefined variable: name in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/pkgfuncs.inc.php on line 248

Package Details: brave-git 0.13.1.5213-1

Git Clone URL: https://aur-dev.archlinux.org/brave-git.git (read-only)
Package Base: brave-git
Description: A web browser that stops ads and trackers by default. Master branch.
Upstream URL: https://www.brave.com/
Licenses: BSD, Apache, custom:MPL2, custom:others
Groups: networking
Conflicts: brave
Provides: brave, brave-browser
Submitter: vorbote
Maintainer: vorbote (mischka)
Last Packager: vorbote
Votes: 8
Popularity: 3.408945
First Submitted: 2016-04-06 13:15
Last Updated: 2017-02-01 00:21

Pinned Comments

vorbote commented on 2016-02-19 12:17

This package was renamed, please use <https://aur.archlinux.org/packages/brave-git/>.

For stable releases, please use <https://aur.archlinux.org/packages/brave/>.

TL;DR: No 32-bit builds for you! Move to a 64-bit OS already! :-)

Brave depends on a prebuilt chromium/blink runtime linked with a node.js shim called electron. Upstream *does not* provide 32-bit binaries. Recompiling electron from scratch will add at least a couple of hours to your build, a lot more for most of you. (Compile chromium or webkit2gtk and you will know exactly what I mean).

Latest Comments

vorbote commented on 2016-04-07 00:00

This package was renamed, please use <https://aur.archlinux.org/packages/brave-git/>.

vorbote commented on 2016-02-25 16:25

I've started packaging the upstream released binaries as brave-browser-bin. I'll ping here when I've uploaded a working PKGBUILD.

jarco commented on 2016-02-25 12:03

I just get an empty browser, No address bar no functionality nothing. No errors either. Anyone else having this?

vorbote commented on 2016-02-23 13:47

I'll look into this latr today. Thanks for the report.

0xR commented on 2016-02-23 12:50

I have installed this package. When I run the brave command I get a window with this error:

Please make sure the webpack devserver is running via:
npm run watch

vorbote commented on 2016-02-19 12:17

This package was renamed, please use <https://aur.archlinux.org/packages/brave-git/>.

For stable releases, please use <https://aur.archlinux.org/packages/brave/>.

TL;DR: No 32-bit builds for you! Move to a 64-bit OS already! :-)

Brave depends on a prebuilt chromium/blink runtime linked with a node.js shim called electron. Upstream *does not* provide 32-bit binaries. Recompiling electron from scratch will add at least a couple of hours to your build, a lot more for most of you. (Compile chromium or webkit2gtk and you will know exactly what I mean).

vorbote commented on 2016-02-19 12:15

@kanazky you are welcome.

kanazky commented on 2016-02-18 21:03

Thanks for posting this :D Excited to try it out!