Warning: file_exists(): open_basedir restriction in effect. File(/srv/http/vhosts/aur.archlinux.org/public/web/locale//en/LC_MESSAGES/aurweb.mo) is not within the allowed path(s): (/srv/http/vhosts/aur-dev.archlinux.org/:/etc/aurweb/) in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/streams.php on line 90
AUR (en) - bitscope-dso

Notice: Undefined variable: name in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/pkgfuncs.inc.php on line 248

Package Details: bitscope-dso 2.9.FE22H-1

Git Clone URL: https://aur-dev.archlinux.org/bitscope-dso.git (read-only)
Package Base: bitscope-dso
Description: Bitscope dso software for oscilloscopes
Upstream URL: http://www.bitscope.com
Licenses: custom
Submitter: s_tec
Maintainer: s_tec
Last Packager: s_tec
Votes: 3
Popularity: 1.072881
First Submitted: 2016-01-21 22:58
Last Updated: 2016-02-01 03:56

Latest Comments

enteenteente commented on 2016-02-02 15:07

I changed the project for easy AUR integration. Now I'd like to ask you to:

1. Add your bitscope-* AUR git projects as submodule to [1]
2. Add a symlink to ../Makefile.modules , ln -s ../Makefile.modules Makefile
3. add vars.mk specifying the Version and Release
4. Tell me your name at github
5. Push your changes to [1]

You can use:
* bitscope-chart [2]
* bitscope [3]

as a reference.

Once done releasing all the packets is as simple as changing all the vars.mk's to the new version and run a "make release" in the toplevel.

[1] : https://github.com/Enteee/bitscope-arch-pkg
[2] : https://aur.archlinux.org/cgit/aur.git/tree/?h=bitscope-chart
[3] : https://aur.archlinux.org/cgit/aur.git/tree/?h=bitscope

s_tec commented on 2016-02-01 03:51

Thanks, but when I made the package, the "H" version was not available in 32-bit, so the package is only up to "G". It looks like they've fixed that, though.

Your git repo is quite nice, but the packages really ought to be in AUR for people to find them. If you want to upload them, I'll be happy to hand or the reins on this.

enteenteente commented on 2016-01-31 14:26

Typo in pkgver? 2.9.FE22H not FE22G , according to [1]

Btw: in order to make this project easy maintainable I created a git repo a long time ago [2]. And I just updated the git project. It should now have a very easy structure and work for the newest version. With a simple make you'll get the source-packets. Feel free to contribute.

[1] : http://my.bitscope.com/download/?p=download
[2] : https://github.com/Enteee/bitscope-arch-pkg