Warning: file_exists(): open_basedir restriction in effect. File(/srv/http/vhosts/aur.archlinux.org/public/web/locale//en/LC_MESSAGES/aurweb.mo) is not within the allowed path(s): (/srv/http/vhosts/aur-dev.archlinux.org/:/etc/aurweb/) in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/streams.php on line 90
AUR (en) - backblaze-b2

Notice: Undefined variable: name in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/pkgfuncs.inc.php on line 248

Package Details: backblaze-b2 0.6.8-2

Git Clone URL: https://aur-dev.archlinux.org/backblaze-b2.git (read-only)
Package Base: backblaze-b2
Description: Backblaze B2 Command Line Client
Upstream URL: https://www.backblaze.com/b2/cloud-storage.html
Keywords: archive backblaze backup cloud storage
Licenses: MIT
Submitter: 2bluesc
Maintainer: 2bluesc
Last Packager: 2bluesc
Votes: 6
Popularity: 0.350988
First Submitted: 2015-10-29 06:31
Last Updated: 2016-10-31 13:36

Latest Comments

1 2 Next › Last »

ams1 commented on 2016-10-31 13:17

0.6.8 fails to run:

pkg_resources.DistributionNotFound: The 'logfury>=0.1.2' distribution was not found and is required by b2

There wasn't a package for logfury, but I've created one for you.

2bluesc commented on 2016-08-05 18:04

@nik10110 thanks! updated.

nik10110 commented on 2016-08-05 17:52

The version on pypi.org is now at 0.6.2, so I suppose that version is considered somewhat stable.
https://pypi.python.org/pypi/b2

It has worked so far for me with the following changes to the PKGBUILD:
pkgver=0.6.2
sha512sums=('6d1e287ccdfdc4105daef7ef702d462202905e9b787ca5c1a165590789c3145a0aec155c3bc3292295801dbdd7bb2b60472b71c2e402ff571a3a558db0828119')

2bluesc commented on 2016-04-27 18:43

@eta-carinae thanks for assembling the python2-portalocker, that was delaying me from pushing the v0.5 release. Just pushed the 0.5.2 with your package included as a dep.

2bluesc commented on 2016-04-27 18:43

@eta-carinae thanks for assembling the python2-portalocker, that was delaying me from pushing the v0.5 release. Just pushed the 0.5.2 with your package included as a dep.

eta-carinae commented on 2016-04-27 17:45

Just a note, the latest upstream (0.5.2) depends on python2-futures and python2-portalocker. The former is in community, and I added the latter to the AUR if you get a chance to update.

2bluesc commented on 2016-01-19 16:39

@Darksonn good catch, it's fixed. Someday people will start writing Python scripts in Python 3. Until then, I've fixed it invoke the Python 2 binary.

Darksonn commented on 2016-01-19 14:55

When I run backblaze-b2 I get the following error:

File "/usr/bin/backblaze-b2", line 897
with os.fdopen(os.open(self.filename, flags, 0600), 'wb') as f:
^
SyntaxError: invalid token

kevincox commented on 2016-01-18 22:50

The b2 name is used by boost build which is a preexisting common program.

supermario commented on 2016-01-18 22:32

Why doesn't this package install the binary to b2?