Warning: file_exists(): open_basedir restriction in effect. File(/srv/http/vhosts/aur.archlinux.org/public/web/locale//en/LC_MESSAGES/aurweb.mo) is not within the allowed path(s): (/srv/http/vhosts/aur-dev.archlinux.org/:/etc/aurweb/) in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/streams.php on line 90
AUR (en) - astrometrynet

Notice: Undefined variable: name in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/pkgfuncs.inc.php on line 248

Package Details: astrometrynet 0.66-1

Git Clone URL: https://aur-dev.archlinux.org/astrometrynet.git (read-only)
Package Base: astrometrynet
Description: Astrometry.net plate-solving
Upstream URL: http://astrometry.net/
Keywords: astrometry astronomy
Licenses: GPL3
Submitter: peterstrapp
Maintainer: peterstrapp
Last Packager: peterstrapp
Votes: 1
Popularity: 0.000241
First Submitted: 2015-11-20 23:42
Last Updated: 2016-01-17 14:51

Latest Comments

Universebenzene commented on 2016-10-04 13:25

Hi, I have some suggestions for your PKGBUILD. As you mentioned netpbm as dependence, I think you may want to install plotting code. First you'd better add:

export NETPBM_INC="-I/usr/include/netpbm/"
export NETPBM_LIB="-L/usr/lib -lnetpbm"

or

sed -e 's/NETPBM_INC\ ?=/NETPBM_INC\ ?=\ -I\/usr\/include\/netpbm/g' -i util/makefile.netpbm
sed -e 's/-L.\ -lnetpbm/-L\/usr\/lib\ -lnetpbm/g' -i util/makefile.netpbm

in the prepare part, as your

make NETPBM_INC="-I/usr/include/netpbm/" NETPBM_LIB="-L/usr/lib -lnetpbm"

doesn't actually works for finding the files of netpbm.
Next there are also a Makefile in libkd directory in which you need to change python to python2. So add it in the sed line.

Finally in order to install the plotting code you should also run make py and make extra in the build part.

Now I'm using astrometry quiet well by using the PKGBUILD edited by myself here: https://paste.gnome.org/pm2ylg7hx
It may just be a reference for the full using of astrometry. Maybe you will have better solution for the full use.

Universebenzene commented on 2016-10-03 05:29

Hi, when I ran solve-field, it said "Couldn't find "plotxy" executable - maybe you didn't build the plotting programs?" Maybe you forgot making extra in your PKGBUILD?
By the way, newer version of astrometry may have been released. However another maintainer's PKGBUILD of astrometry in AUR has compiling problems. Maybe you'll help him solve the problem?