Warning: file_exists(): open_basedir restriction in effect. File(/srv/http/vhosts/aur.archlinux.org/public/web/locale//en/LC_MESSAGES/aurweb.mo) is not within the allowed path(s): (/srv/http/vhosts/aur-dev.archlinux.org/:/etc/aurweb/) in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/streams.php on line 90
AUR (en) - arc-firefox-theme

Package Details: arc-firefox-theme 50.20161114-1

Git Clone URL: https://aur-dev.archlinux.org/arc-firefox-theme.git (read-only)
Package Base: arc-firefox-theme
Description: Official Arc Firefox theme
Upstream URL: https://github.com/horst3180/arc-firefox-theme/
Licenses: custom:MPL2.0
Submitter: J5lx
Maintainer: J5lx
Last Packager: J5lx
Votes: 11
Popularity: 0.539129
First Submitted: 2016-06-12 09:19
Last Updated: 2016-11-16 22:24

Latest Comments

J5lx commented on 2016-11-04 20:48

I updated the dependencies accordingly.

jpope commented on 2016-11-02 15:34

`community/gtk-theme-arc` in has been replaced/renamed to `community/arc-gtk-theme`.

J5lx commented on 2016-09-06 12:37

I have only one version of Firefox listed in the deps - `firefox'. All the other packages you see in that list are only there because *they* have listed `firefox' in `provides', i.e. they claim that they work as a drop-in replacement for the standard firefox package.[1] The AUR detects that and automatically lists such packages in parentheses after the "actual" `firefox' package. If `firefox-aurora' doesn't list `firefox' in `provides', it means that a) the maintainer of the aurora package forgot to add it or b) the aurora package doesn't work as a drop-in replacement for the regular firefox. In either case you should ask the maintainer of `firefox-aurora' (currently AlexTalker) about it, because it's not something that I could reasonably fix in this package (at least to my knowledge). I hope this helps.

[1] See the ArchWiki for details: https://wiki.archlinux.org/index.php/PKGBUILD#provides

rakuu commented on 2016-09-05 22:32

It is different, yes, but you have every other version of firefox listed in the deps currently.

J5lx commented on 2016-09-05 10:32

I don't think that would solve anything. Looking at firefox-aurora's PKGBUILD, it seems that the aurora version is entirely separate from the stable one (different install directories, different desktop entries etc). You'd probably have to alter the build procedure for this theme as well to make it work with aurora. Plus, in the release announcement for the current version of the theme[1] it explicitly says "Firefox 48 support", so I guess additional work is required to make it work well with new versions of Firefox.

[1] https://github.com/horst3180/arc-firefox-theme/releases/tag/48.20160802

rakuu commented on 2016-09-05 09:08

Should add firefox-aurora to the dependencies

KarlFiabeschi commented on 2016-08-01 08:32

very nice in combo with arc-theme, ty

Vosky commented on 2016-06-14 16:48

Please add "zip" as dependencie.
I had error during building package.
Thanks !