Warning: file_exists(): open_basedir restriction in effect. File(/srv/http/vhosts/aur.archlinux.org/public/web/locale//en/LC_MESSAGES/aurweb.mo) is not within the allowed path(s): (/srv/http/vhosts/aur-dev.archlinux.org/:/etc/aurweb/) in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/streams.php on line 90
AUR (en) - aqemu

Notice: Undefined variable: name in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/pkgfuncs.inc.php on line 248

Package Details: aqemu 0.9.2-1

Git Clone URL: https://aur-dev.archlinux.org/aqemu.git (read-only)
Package Base: aqemu
Description: QEMU GUI written in Qt5
Upstream URL: https://github.com/tobimensch/aqemu
Licenses: GPL2
Submitter: None
Maintainer: fordprefect
Last Packager: fordprefect
Votes: 92
Popularity: 2.313025
First Submitted: 2008-10-17 11:02
Last Updated: 2016-05-31 13:06

Latest Comments

« First ‹ Previous 1 2 3 4 5 Next › Last »

schmoemi commented on 2011-02-07 17:13

New pkgbuild acc. to cyberpatrol's suggestions. Update to v0.8.1.

valr commented on 2010-12-26 19:02

http://pastebin.com/MpRanc8C
- 0.8.1
- dependency on QT version changed (as per doc), dependency on qemu added
- variable set by default: WITHOUT_EMBEDDED_DISPLAY=on -> no dependency on libvncserver

schmoemi commented on 2010-12-26 18:06

AQEMU 0.8.1 is out

Gimmeapill commented on 2010-12-16 11:44

libvncserver is not optional, it should be moved to the depends

schmoemi commented on 2010-09-06 11:46

I also suggest that a qemu GUI should have qemu as dependency, shouldn't it?

Anonymous comment on 2010-08-24 01:56

Installed aqemu with libvncserver support. It is disabled by default at runtime and can be optionally enabled. So I'd suggest building aqemu with libvncsupport.

So I'd suggest using the first method from my last comment. But, please, don't use the whole commenting and uncommenting stuff as you do it now. Keep it simple, in case of doubt provide as many features as possible and think of users of AUR wrappers like yaourt, aurbuild, clyde etc.

Anonymous comment on 2010-08-24 01:43

What schmoemi wants to say is that aqemu fails to build with this PKGBUILD. It stops with these error messages:

CMake Error: The following variables are used in this project, but they are set to NOTFOUND.
Please set them or make sure they are set and tested correctly in the CMake files:
LIBVNCCLIENT_INCLUDE_DIR
used as include directory in directory /var/tmp/aurbuild/build/aqemu/aqemu/src/aqemu-0.8
LIBVNCCLIENT_LIBRARIES
linked by target "aqemu" in directory /var/tmp/aurbuild/build/aqemu/aqemu/src/aqemu-0.8

-- Configuring incomplete, errors occurred!
Aborting...


To fix it you need to change the PKGBUILD, because libvncserver is optional but not an optdepends. If aqemu shall have embedded display (vnc) support you need libvncserver as depends. Otherwise you must disable vnc support at build time.

So please change the PKGBUILD to one of the two possible methods.

Either move libvncserver from optdepends to depends and change the lines

cmake . \
-DCMAKE_INSTALL_PREFIX=/usr/
# -DWITHOUT_EMBEDDED_DISPLAY=on
to
cmake -DCMAKE_INSTALL_PREFIX=/usr

or remove optdepends and libvncserver as dependency completely and change the lines

cmake . \
-DCMAKE_INSTALL_PREFIX=/usr/
# -DWITHOUT_EMBEDDED_DISPLAY=on
to
cmake -DCMAKE_INSTALL_PREFIX=/usr -DWITHOUT_EMBEDDED_DISPLAY=on

Both methods work. I prefer not having an embedded display, but I think it would be better to offer this feature if it can be optionally turned off at runtime.

Btw., the cmake line needs to be in one line in the PKGBUILD.

schmoemi commented on 2010-08-23 14:37

The package seems not to build without libvncserver

schmoemi commented on 2010-08-20 23:31

Hm, it may not _really_ depend on qemu/qemu-kvm, but does a frontend/GUI package for qemu make any sense without qemu/qemu-kvm?

Anonymous comment on 2010-07-12 07:53

mpsnets
done
tony
Next time just rebuild package
libvncserver moved to optdepends
qemu exclude from depends (doesn't really depend from qemu, qemu-kvm)
Don't mark out-of-date when testing version available. Try to use http://aur.archlinux.org/packages.php?ID=32437 instead.