Warning: file_exists(): open_basedir restriction in effect. File(/srv/http/vhosts/aur.archlinux.org/public/web/locale//en/LC_MESSAGES/aurweb.mo) is not within the allowed path(s): (/srv/http/vhosts/aur-dev.archlinux.org/:/etc/aurweb/) in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/streams.php on line 90
AUR (en) - android-sdk

Notice: Undefined variable: name in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/pkgfuncs.inc.php on line 248

Package Details: android-sdk 25.2.5-1

Git Clone URL: https://aur-dev.archlinux.org/android-sdk.git (read-only)
Package Base: android-sdk
Description: Google Android SDK
Upstream URL: https://developer.android.com/studio/releases/sdk-tools.html
Licenses: custom
Submitter: None
Maintainer: xyproto
Last Packager: xyproto
Votes: 1420
Popularity: 11.114531
First Submitted: 2007-11-12 19:26
Last Updated: 2017-01-25 11:30

Sources (7)

Pinned Comments

xyproto commented on 2016-08-22 08:39

* If the android-sdk license had allowed binary redistribution, this would probably have been a package in [community] instead of in AUR.

* If there are problems with conflicting files, you can check which package owns them with `pacman -Qo`. If no package owns the file, it has most likely been placed there by you, the user (possibly using the SDK Manager). You can remove the conflicting files, either with `rm` or by installing the android-sdk package by force.

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 ... Next › Last »

yan12125 commented on 2016-05-14 20:20

25.1.6 is out. The link is https://dl.google.com/android/repository/tools_r25.1.6-linux.zip and the SHA1 checksum is a375003033774604d1426eb2d33ce6e507c95900. These values can be found in https://dl.google.com/android/repository/repository-11.xml

xyproto commented on 2016-05-14 16:36

Thanks jryan, removed libstdc++ from the package.

jryan commented on 2016-05-14 04:23

Having some issues with the fact that android-sdk provides it's own libstdc++.so.6 Basically, I can't get hardware acceleration in the emulator. Removing the files seems to fix the issue, so that android uses Arch's version.

Not sure if I should report this to Android SDK people or not?

edit: I added a section under troubleshooting for this on the wiki page

xyproto commented on 2016-04-24 15:58

Version 25.0.0 is mentioned in the SDK Tools Notes (https://developer.android.com/tools/sdk/tools-notes.html), but I can't find a working download for that release yet. Unflagging as out-of-date.

Please provide a link if flagging this package as out-of-date and the version number can not be seen on the main SDK page (https://developer.android.com/sdk/).

xyproto commented on 2016-04-24 00:24

Please post comments about problems with the ncurses5-compat-libs package here instead: https://aur.archlinux.org/packages/ncurses5-compat-libs/

plmosqueda commented on 2016-04-23 12:52

This one worked:

$ gpg --keyserver pgp.mit.edu --recv-keys F7E48EDB
gpg: key F7E48EDB: public key "Thomas Dickey <dickey@invisible-island.net>" imported
gpg: no ultimately trusted keys found
gpg: Total number processed: 1
gpg: imported: 1

is the gpg to build ncurses5-compat-libs

I-sty commented on 2016-04-20 14:13

==> Validating source files with md5sums...
ncurses-6.0.tar.gz ... Passed
ncurses-6.0.tar.gz.asc ... Skipped
==> Verifying source file signatures with gpg...
ncurses-6.0.tar.gz ... FAILED (unknown public key 702353E0F7E48EDB)
==> ERROR: One or more PGP signatures could not be verified!
==> ERROR: Makepkg was unable to build ncurses5-compat-libs.
==> Restart building ncurses5-compat-libs ? [y/N]
==> ---------------------------------------------
==> n

xyproto commented on 2016-04-18 14:13

Added ncurses5-compat-libs as a dependency.

Doctor_Drive commented on 2016-04-15 09:50

Software-emulated emulator requires libncurses.so.5
The package should depend on ncurses5-compat-libs

xyproto commented on 2016-04-13 13:39

Updated the hash sum.